CDN F Score on Gmetrix YSlow



I am a bit confused, about my score, and I am using CloudFlare CDN (my hosting provider Bluehost gave me my CloudFlare CDN #. I am wondering if it’s correct? Where can I check to make sure I am using the correct CDN? Because I get the following error on the on Gmetrix YSlow.

Thanks a bunch

Any thoughts on what could be causing this problem

There are 144 static components that are not on CDN.


You didn’t need to link all the resources and all the images… :roll_eyes: I will delete all the links, it’s just basically spam.

GTMetrix doesn’t recognize Cloudflare’s CDN, since it serves content in its own place. You don’t have to worry about that. You can confirm that Cloudflare is working by checking that the resources have the CF Headers…


Thank you for the quick response, I am new to wordpress web development. :blush:.

Thanks again for your help!


So, non-proxy CDN’s usually have their own CNAMEd subdomain (,,, etc), but because CloudFlare is reverse-proxy, it puts the whole domain in the CDN. GTMetrix can’t automatically detect this. The permanent fix is to actually go into your user preferences on GTMetrix, and there is a field for CDN domains. Define your domain there, and that F will turn into an A. Hope that helps!


Hi Mike,

I already had a CDN for Cloudflare…Bluehost gave me this CDN to put in for all Cloudflare CDN’s……Does this look correct? I had that CDN in the CDN box, and I still got a F.


If it helps, here’s how mine is set.


I also pulled up your site and have a few pointers on some things you can do to improve your performance. Welcome to the web dev world!


Hi Mike,

Thank you so much in helping me ::innocent:…when I clicked on your link, it gave me some info…and I clicked on my link it returned an error “Can’t connect securely to this page”…Do you think Bluehost gave an incorrect Cloudflare CDN?


It doesn’t look like it’s incorrect, just incorrectly configured. The error I saw was a TLS mismatch, so there’s something going on there. You should be able to just define * and, and anything else you’re pulling from a CDN, and be good to go.


Okay, thanks…so the correct path URL should be …


I’m honestly not sure why you would need all that. Just the domain as you would visit it in the browser should suffice, so and * Everything else is for CloudFlare and blue host dns to figure out.

Michael Burroughs

This message was dispatched from a mobile device. Please excuse the brief nature of it’s contents. No trees have been harmed in the creation or transmission of this message, however several electrons were terribly inconvenienced.


Ok, thanks!

closed #13

This topic was automatically closed after 14 days. New replies are no longer allowed.