Cant use Cloudflare with Unitpay

When i apply security settings in Cloudflare panel my payment handler throws to me error in Unitpay control panel.

This is page rules:

My payment handler works fine because when i turn off Cloudflare Proxy mode for my REPLACED domain name. Unitpay payment system works fine.

What i did wrong? Help me, please.

Unitpay control panel answer for my payment handler when Cloudflare proxy is ON

My IP address rules:

This IP Addresses I took from unitpay documentation

You have been very thorough with your settings.

I don’t know why it would be an empty response, though. Cloudflare usually includes a 4xx or 5xx response code if it’s not a successful 200 connection.

Have you checked your server logs, or even the Cloudflare Firewall Event Log?

1 Like

Yes I did. Nothing about Unitpay system or Unitpay known addresses

At this point, I suggest you create a ticket here and then post the # in this thread.

To contact Cloudflare Customer Support, login & go to and select get more help. If you receive an automatic response that does not help you, please reply and indicate you need more help.

1 Like

Sorry, i m new here and i didnt understand about #. What does it means?

Sorry, the ticket #. It’s usually six digits. You’ll get that number once you submit your ticket request.

1 Like

Hi @cptrex, did changing the rule to Bypass, instead of Allow solve the issue?

Leaving this here for future reference,


Hello, I solved my problem. Issue was in TLS version. cant work via 1.3 TLS version but in Firewall rules thats function was enabled. When i changed TLS version to 1.2 Unitpay handler returned me “format error response” that means my payment-handler gives wrong JSON answer to unitpay query(but it isnt, because when i turn off Cloudflare proxy all works fine).
A step earlier, I deleted the rules in the IP lists and transferred the rules with IP addresses to the Firewall with a bypass, as you recommended, but it did not help. And when I saw that the answer from was no longer an empty answer, I went to watch the Cloudlfare`s firewall events. And there I found the following log

As you can see Cloudflare blocked Unitpay query to my site according Bot Fight mode rule. So the last step was revoke deleting rules in IP Address list and set “Allow” again. And its works!


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.