Can't solve "Insecure Content Blocked" error after so many days R&D

Hi !

My site https://www.godswhistleblower.org shows “Insecure Content Blocked” error on chrome and Firefox has “Firefox has blocked part of this page that are not secure” error.

I troubleshoot so many days follow so many steps but not solved.

Regards

Mixed Content error:
42%20AM

Hi !

Thanks for your help. I already done Idea number 2,3,4 already but my problem shouldn’t fix.

I don’t know how to implement idea number 1 and 5. as I am not so much good technical person.

I still facing the same issue.

Regards

Bummer. #5 is my favorite. If you have a way to look at and edit the files on your server (cPanel?), there should be a .htaccess file in the same directory as your web files. You may have to toggle a “View Hidden Files” option because the file starts with a dot.

Add the following line anywhere to that .htaccess file:
Header always set Content-Security-Policy: upgrade-insecure-requests

Hi ! sdayman,

Thanks for guiding me …

I find that .htaccess in the my c panel --> File manager and the path is /godswhistleblower.org/htdocs/.htaccess
I open and paste your line and paste your line at the end of that. After my files look like below…

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
Header always set Content-Security-Policy: upgrade-insecure-requests

And THAN TANA NA !!!

My problem was solve.

Thanks man… You made my day. I am facing the same problem till Aug-2018 and I haven’t much technical knowledge and also no one like you guided / teaching me before.

So, man again lots of thanks to you… Have a great day !

Regards


This is I got another solution for community

Add plugin " SSL Insecure Content Fixer" and it’s setting choose “simple” and at last choose option recommended for cludflare “HTTP_CF_VISITOR (Cloudflare Flexible SSL); deprecated, since Cloudflare sends HTTP_X_FORWARDED_PROTO now”

Enjoy !!!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.