Cant setup jetpack since updating nameservers

Hi everyone,
It seems that when I recently updated my name servers to Cloudflare’s, Jetpack locked me out of my site. For fastest fix, I deactivated Jetpack, and was able to login. The issue now is, that I’m not able to use WooCommerce Shipping & Taxes without Jetpack.

When I try to re-install Jetpack on my site (I planned to re-activate and change settings so it would no longer lock me out), I get this message: “The Jetpack server was unable to communicate with your site https://cleanscamerasupport.com/ [HTTP 403]. Ask your web host if they allow connections from WordPress.com. If you need further assistance, contact Jetpack Support: http://jetpack.com/support/”.

None of this was an issue until I changed nameservers, and it was the only change I’ve made.

Thoughts?? I’m go to de-activate Jetpack again for now.

It’s a good idea to google it first, FYI. This is the first result for “jetpack cloudflare” and should solve the problem:

1 Like

Hey Judge, I did indeed try Googling it first and following these steps – to no avail.

I was able to troubleshoot this myself doing the following steps (again… this assumes that you already have Cloudflare running on your site and that Jetpack setup button isn’t working).

  1. Add a page rule as outlined in this article: Use Jetpack and Cloudflare on your WordPress site.

  2. Temporary pause Cloudflare as outlined in this article: How do I temporarily disable Cloudflare?

  3. Then click “setup” and Jetpack should work.

  4. Make sure Jetpack’s security functions are turned OFF as outlined in this article: Protect

  5. Enable Cloudflare back on.

You’ll be in business!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.