Can't set up domain email with Gmail

I’ve been loving the custom domain email reception that Cloudflare allows with my site, but after trying to set it up in gmail to be able to send emails as well I am unable to do so. I have attempted following multiple guides, using gmail’s device password to sign in, etc. and nothing has worked in the month that I have been trying. Does anyone know how I could fix this? I get to the sign in part on gmail where it asks for my user, pass, and if it should use SSL or TLS and then afterwards it fails to connect to the server. I am trying to use route1 dot mx dot Cloudflare dot net but have one through three available in my MX records.
Please excuse the “dot” as I am not allowed to post links.

Thanks for your help and time!

Cloudflare doesn’t provide outbound email services. Any settings to send email should involve your email outbound settings from your email provider

1 Like

I realize this. Google does. But I am unable to link the provided email from Cloudflare to my google account to be able to add outbound services.

Setting up outbound mail is rather … involved, largely due to necessary anti-spam measures. I don’t think you can use GMail servers to send mail using a non-GMail address.

Then why are there so many instructional guides and videos on how to do it? My last company set their email up this way. I do not plan on setting up an email server on my VPS. I just want to be able to reply to emails sent to my domain email.

Well, okay, I should have qualified.

There are two ways of doing it. Firstly, the GMail client can be configured to use a different SMTP server. This requires there to be an existing outbound SMTP server for the domain, which Cloudflare doesn’t do. The other is Google’s own Workspace service, which has Google doing mail hosting for you at a per-user fee.

There are some services that specialise in providing outbound SMTP, I believe, but they tend to be oriented towards apps and I don’t know if the terms of service allow them to be used this way. Might be worth looking into, though.

I was able to finally get it working after changing the email on the second screen of the gmail add account page. For anyone with a similar problem, first use the email you want to be able to send from and then on the second screen sign into your gmail as usual.

Thanks for the help

The ‘second screen’ being the one asking for the SMTP server, I presume?

It’s not ideal, but it can be done.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.