Can't set Cloudflare as NS


#1

Hey,
I tried to switch my DNS to Cloudflare, but it’s not possible for one of my domains.
there is a DENIC Test https://www.denic.de/service/tools/nast/ and it shows “Inconsistent set of NS RRs (IP, NS host names)”.

I even tried to remove the domain and re-add it, but still not working.

Thanks for the help.


#2

Where are you trying to set the NS? It should be with your domain registrar, and they’re generally not too picky about which Name Servers you set.


#3

I tried to set the NS at united-domains.de, but I already tried to fix it with their support.
Well, they said it’s not with them.


#4

Which Cloudflare name servers and IP addresses are you trying to use? That error usually means you’re trying to use the wrong IP address for that name server.

I just tried that test with my domain and my assigned Cloudflare name servers and the test was successful.


#5

I can just put in the domain ernest.ns.cloudflare.com and vera.ns.cloudflare.com, no need / possibility for the IP.

My other domains with the same name servers are working, just this one won’t work.


#6

Do you mind to try/test this https://www.denic.de/en/service/tools/nast/
your test is probably successful, but mine wasn’t. I hope the Cloudflare TEAM can help.


#7

Is this two different problems?

  1. When I run the denic test, I can get that error message by inputting my domain with your name servers. It gives me an error because the name servers I entered did not match the name servers shown in WHOIS. I expect this to fail if your registrar won’t let you update your WHOIS information for the Cloudflare name servers. If I enter my domain with my Cloudflare name servers, my test is successful.

  2. I’ve had Registrars not let me set a name server because it didn’t recognize the desired name servers as valid DNS machines. This is something the registrar has to fix. I don’t know why their Support people are saying it’s not with them. ernest and vera are legitimate name servers.


#8

This is true, but one of my domains is with the same registrar and with this one (same nameservers) it worked right away.


#9

Just to confirm…You can’t change the name server at your registrar? And you have .de domains there that set up ok? That really sounds like an issue at their end.


#10

We run into this fairly often. DENIC does not allow you to use a nameserver if asking it for NS records returns a response that does not include that nameserver. This is intended to prevent users from shooting themselves in the foot with an invalid configuration.

In our case, we return NS records for either the last known active registration (even if it has since been deleted) or the earliest pending registration. These NS records are eventually purged if there is no active registration, but that process takes some time (~2 weeks).

Because of this, we can, on request, purge those records early. This does also wipe out your pending registration, but if you recreate it we’ll return your nameservers and you’ll be able to configure them with DENIC.


Inconsistent set of NS RRs (IP, NS host names) cloudflare
#11

@ezhka who do I need to contact to purge those records or can you do it?
Thank you


#12

You’d have to open up a Support Ticket at support.cloudflare.com or email support at cloudflare dot com from your account’s email address.


#13

@sdayman thank you for the help, I just opened a support ticket.