Can't seem to forward properly

Hi community,

I am trying to forward www.harvester.academy and harvester.academy to www.mobilize.network. I have read the documentation and thought that I have taken all the right steps. But https://www.harvester.academy/ is not forwarding to www.mobilize.network. What am I missing?


@domjh I followed your tutorial step by step for forwarding one domain to another, but no luck. Not sure what I missed. Redirecting One Domain to Another

Hi @saqib,

The root domain does seem to redirect properly:

$ curl -I harvester.academy
HTTP/1.1 301 Moved Permanently
Date: Tue, 11 May 2021 07:21:19 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Tue, 11 May 2021 08:21:19 GMT
Location: https://mobilize.network/
cf-request-id: 09fbe64bee00004bdddabb8000000001
Report-To: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?s=DAPaexWhs48QgJxeidL2vVtWwBQkC14q9of4WeBPgIyWIbQAoQYdKJS0OxLxNdMbhOkZnA%2BQ00YSB0T7fC87XFjrv2yEsrKUg13osc8VrMxKOJmk3MSqE4BuZKB4JQ%3D%3D"}],"group":"cf-nel","max_age":604800}
NEL: {"report_to":"cf-nel","max_age":604800}
Server: cloudflare
CF-RAY: 64d9a6597d614bdd-AMS
alt-svc: h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400

However, the www shows a Heroku 404 page, which shouldn’t be the case, given your setup.

Can you check on the DNS tab that your nameservers are:

cody.ns.cloudflare.com
riya.ns.cloudflare.com

Just so we know that you’re making changes in the right account and that your domain is not active in another Cloudflare account.

If those match, I do remember a similar issue from a while ago which was a Heroku/Cloudflare issue and something that they had to resolve. I can’t remember the exact issue, but I’ll see if a member of staff can have a look at this thread.

Having talked to some of the other MVPs about this, it seems that you will need to get in contact with Heroku and ask them to release your hostname from their Cloudflare configuration.

It seems that, as Heroku is a Cloudflare customer themself, when you validated your domain with them, they took control of the Cloudflare configuration. Once they remove it on their end, the configuration in your dashboard should then work as expected.

2 Likes

Hi @domjh thank you for your attention to this. I checked and yes, I am in the right account and have the right NS.

Moreover, I was not with Heroku. www.harvester.academy was a website hosted on Squarespace. I simply changed the domain name for the website to www.mobilize.network and want to route the old domain to new. I am not sure how Heroku became part of the picture and if they would be under any obligation to speak with me. This is a real headscracher. Any thoughts?

That is interesting, and indeed odd! I suspect you will need Cloudflare to look at this and see if your zone is tied to a SaaS config and where that has come from.

Tagging @Chris_M for input here, but I suspect you may need to create a ticket with support.

I suspect that there may be a SSL for SaaS on www.harvester.academy as well. Please go ahead and submit a ticket and we’ll be happy to help.

3 Likes

@Chris_M thank you. I have submitted a ticket [2156080].

I’ve applied a fix and see the site loading as expected now. Looks like it was the SSL for SaaS still active from the previous configuration. Thank you for all the patience here!

3 Likes

You rock @Chris_M and @domjh! Thank you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.