Can't see https on any pages


#1

Hi,

the https not appearing in my address bar. And when I try to type https:withmyaddres.com it says that its not a secure site, that my connection is not private. But I added my website in cloudflare. Why isn’t it working?

Thank you.


#2

Have you turned on SSL in Cloudflare’s Crypto settings tab? If so, does it say that Status is Active Certificate?

Is your Cloudflare DNS entry for your site in :orange: mode?

If all the above looks good, also turn on Always Use HTTPS in the Crypto tab.


#3

yes all is done.


#4

yes all is done. I’ve added other websites and it’s working it’s only for this one that it’s not.


#5

What’s the URL?


#6

#7

Some elements on the page are set to use HTTP.


#8

There are two (1, 2) pictures on your home page which are requested over http rather than https.
Both are also available over https so you just need to fix your scripts.


#9

Thank you. I didn’t do any changes and now it’s working fine!?


#10

:slight_smile: Im reading and learning but base on our findings mix content was the issue so why is it working all of the sudden would cloud flare or someone enable automatically the Automatically the HTTPS Rewrites??

Automatic HTTPS Rewrites helps fix mixed content by changing “http” to “https” for all resources or links on your web site that can be served with HTTPS

.


#11

You may have enabled it yourself (Under the Crypto section of your dashboard)


#12

TRUE GOOD OBSERVATION jaja but I was refering to the original post but who knows maybe I thought it was my dashboard and I switch it on to save the day!!:joy::joy: