Can't run AutoSSL on cPanel due to https redirect

Hi there, I can’t run the AutoSSL on my cPanel due to HTTPS redirection on Cloudflare, tried all guides already.
I tried switching Off [Always use HTTPS & Automatic HTTPS Rewrites]
Tried pausing Cloudflare on sites, then run the auto SSL on my cPanel
Tried all options for “SSL/TLS encryption mode”
checking my .htaccess for any redirects,
I have no redirections set up at all plus the option to force HTTPS is off at the moment.
please see the screenshot of my domains: Screenshot by Lightshot

Here is the reply I got from my cPanel support team:

“Thank you for your patience.
Part of the problem is that Cloudflare is still auto-redirecting to use SSL even though Always use SSL is off. You will need to discuss with Cloudflare why it continues to do this.”
screenshot: Screenshot by Lightshot

I did run auto SSL multiple times in the past (until yesterday) and all I needed to do was to set Always use HTTPS OFF on Cloudflare, but this time nothing is helping despite I have not changed any settings on my server recently.

I tried using let’s encrypt instead but was no difference so I switch back to cPanel AutoSSL

Please help me resolving this issue quick as my sites are not working at the moment.
I appreciate your help in advance.

Hi,

Do you have any Page Rules in place? If so, do you mind sharing a screenshot here (obfuscate any IP addresses)

Do you have any Cloudflare Worker running? Or any Cloudflare App that may cause the redirect?

If not, I’d suggest you open a ticket with Cloudflare Support and post the # here, so that @cloonan may monitor it.

1 Like

Hi, thank you for the reply.
No, I don’t have any of them, no page rules no apps.
I have opened a ticket earlier [#2170196]
I would appreciate looking at it, please.

1 Like

I have disabled all proxy and used DNS only on all my domains.
last reply from cPanel team is:
"Unfortunately, these redirects are still occurring despite being disabled in Cloudflare. I ran a for loop to curl through all the domains and check for redirections and the server it comes from

Could you try temporarily disabling the proxy on these domains as a whole to see if that allows the SSL renewals to complete? If not, you will need to reach out to Cloudflare to determine why these redirects continue to occur, as we would be unable to manage these redirects on our end.
"
@floripare :
No, I don’t have any of them, no page rules no apps.
I have opened a ticket earlier [#2170196]
I would appreciate looking at it, please.

1 Like

It’s totally your server that’s doing the redirect:

(I forgot to highlight the last line as well: requiressl)

3 Likes

Thank you for confrming that, but i’m really confused here as cpanel team comfims the opposite,
can you give me some hints/guide on how to resolve it?
Regards.

I haven’t seen their evidence. You’ve seen mine.

1 Like

Here are their evidances (According to them):
Screenshot by Lightshot
Screenshot by Lightshot

They need to test against the origin. Whatever the origin does will be proxied by Cloudflare.

I recommend you go with their suggestion:

Remember that it takes five minutes for DNS changes to take effect.

2 Likes

I disabled the proxy long ago but made no difference

So we’re back to “It’s your server.” You did what they suggested, and it’s still not working. Did you let them know?

1 Like

Yes, waiting for their reply

1 Like

If below behaviour can help a bit (if already not written):

  1. In case of AutoSSL and cPanel, for few of my domains, I usually and temporarly switch from :orange: to :grey: cloud my DNS records at Cloudflare dashboard.
  2. After that, I Purge the cache at Cloudflare and wait for few minutes just in case to apply the changes.
  3. Then I run the AutoSSL process in the cPanel interface.
  4. When the SSL certificate is renewed successfully, I switch back the :grey: to :orange: cloud.

Here is what they said "
As for what was causing the redirects previously, I cannot say for sure. Although the circumstances of the situation lead me to believe that CloudFlare may have been redirecting the domains. I say this because it seems that the redirection problem has gone away now that the CloudFlare proxy has been disabled.
"

with that said, the problem is still present and i still can’t run the autoSSL

If currently the DNS records are :grey: cloud, could it be the path to /.well-known/ is being blocked by some security or Firewall rule at Cloudflare dashboard?, or maybe the cPanel TXT record with some “dcv test” value for AutoSSL is needed to be added to the Cloudflare DNS to make sure AutoSSL would run propperly?

1 Like

They say:

But you say:

I still don’t get why Cloudflare is still getting dragged into this. If DNS is :grey:, or you’ve toggled “Pause Cloudflare on Site” from the overview page, there’s no reason to continue discussing this here.

So now you’re left with two options:

  1. If your cPanel permits, upload an origin certificate from Cloudflare.
  2. Stop using Cloudlfare completely (go back to your old name servers).
2 Likes

As you said after disabling the proxy it was the cPanel part as redirection was not taking place anymore.
they have solved the issue by removing the currently installed SSL and rerunning the AutoSSL.

Thanks all.

1 Like

This post was flagged by the community and is temporarily hidden.