Can't resolve cathkidston.com with 1.1.1.1/1.0.0.1

$ ./test.sh
++ dig cathkidston.com @1.1.1.1

; <<>> DiG 9.11.5-P4-5.1+deb10u2-Debian <<>> cathkidston.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 4483
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 16 ("..")
;; QUESTION SECTION:
;cathkidston.com.               IN      A

;; Query time: 2875 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Wed Nov 25 12:55:44 GMT 2020
;; MSG SIZE  rcvd: 50

++ dig cathkidston.com @1.0.0.1

; <<>> DiG 9.11.5-P4-5.1+deb10u2-Debian <<>> cathkidston.com @1.0.0.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 17963
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 16 ("..")
;; QUESTION SECTION:
;cathkidston.com.               IN      A

;; Query time: 19 msec
;; SERVER: 1.0.0.1#53(1.0.0.1)
;; WHEN: Wed Nov 25 12:55:44 GMT 2020
;; MSG SIZE  rcvd: 50

++ dig cathkidston.com @8.8.8.8

; <<>> DiG 9.11.5-P4-5.1+deb10u2-Debian <<>> cathkidston.com @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13712
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;cathkidston.com.               IN      A

;; ANSWER SECTION:
cathkidston.com.        299     IN      A       94.199.146.85

;; Query time: 59 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Wed Nov 25 12:55:44 GMT 2020
;; MSG SIZE  rcvd: 60

++ dig +short CHAOS TXT id.server @1.1.1.1
"MAN"
++ dig +short CHAOS TXT id.server @1.0.0.1
"MAN"
++ curl -H 'accept: application/dns-json' 'https://cloudflare-dns.com/dns-query?name=cathkidston.com&type=AAAA'
{"Status":2,"TC":false,"RD":true,"RA":true,"AD":false,"CD":false,"Question":[{"name":"cathkidston.com","type":28}]}

It seems like the upstream nameserver is not reachable from some of our PoPs, I’ve added a workaround and will look into it.

Cheers!