Can't reach my server when proxied?

I’ve searched and looked but can’t seem to find my issue. I have been using CF for years have setup my domain with DNS Only. But a few days back I thought - hey lets use CFs function to hide my real IP. So I switched Proxied to on and waited.
Now when I ping my domain I get an CF IP - yay!
When I try to access my subdomain services behind an nginx reverse proxy ( Swag) the services cannot be reached. No error no nothing just “Cannot be reached”.

Now I tried to go to domain.tld and that worked, the cnames I have configured does work, but the wildcard that Swag is supposed to handle doesn’t seem to work.

This is me that has done something wrong here… but as of now I cannot see what I have done wrong. Can someone point me in the right direction, please?

Change your encryption mode to “Full Strict”.

Oh I do hope it is that simple. :smile:
I have switched to Full Strict now, but I guess it takes more than a few seconds.

Also I am about to change reveres proxy to Traefik someday when I have a lot of time on my hands.

Switching should be pretty much instant. Do you have any page rules?

No, I do not.
Now it is working! :slight_smile:

Thank you for your help @sandro :heart_eyes:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.