Can't pass the "needs to review the security of your connection before proceeding." checks on my Edge browser

Every site that uses Cloudflare protection is blocking me, it just keeps bringing up that page over and over.

I have recorded the HAR for the Nexusmods sign in page

Here is the HAR file:!Ato-a1gkiH5Uget91jTTQjTg3xjjCg?e=BhEDob

Here is the sign in page URL:

The pages that use Cloudflare security work in other browsers on my machine Chrome & Vivaldi so I believe the issue is solvable. Edge is my main browser, I have tried disabling uBlock for the sign in page but it’s still looping.

Is anyone able to spot something wrong in the HAR?

Hi @AndrewF, can you reproduce this on a fresh installation of Edge? What other extensions do you have enabled? Thanks!

I have same problem. Removed Iobit extension, then problem solved

Have this same problem using BRAVE on kubuntu with or without vpn. Firefox works fine.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.