Can't Open the page

Hi all,
I have testing with an website tusbalonazos dot com* and I connected this one with my Cloudlfare account, but I have some issues with the SSL/HTTPS in the website, please see attached images, appears I have a problem with secure connection. I’m trying all to solve this but I can’t do this, I appreciate your help with this issue.

Greetings,

Thank you for asking.

I got SSL_ERROR_NO_CYPHER_OVERLAP error shown in my Web browser.

Before moving to Cloudflare, was your Website working over HTTPS connection?

Kindly, before doing anything at Cloudfalre settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Check with your hosting provider / cPanel AutoSSL / ACME.sh / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Hi thank you for your response, yes, before I pointed the website DNS to the Cloudflare, this one wroked correctly with the HTTPS connection via Let’s Encrypt.

Hi @andresg

Besides what @fritex suggested to you, you can also try this

I found this discussion about something similar here

I got a solution,
so, first I am using wordpress VIPGo environmnet to route the website, so the problem was with the let’s encrypt cert, so in the Cloudflare configuration SSL/TLS → Edge Certificates I configured as:

  • Always use HTTPS
  • Enabled TLS 1.3
  • Enabledd Automatic HTTPS Rewrites
  • And the most important: Disable Universal SSL

So, now the website works with the original Let’s Encrypt Cert.