Cant manage/renew expired domain

I need to renew a domain that expired on May 24 but the page refreshes before I can click renew.

I cant access the Manage page list for this domain. When I click Manage, the Manage Page flashes briefly and I’m redirected back to the Manage Domains Main Page. If I try to open it in a new tab, I get a 403 error and then I am redirected to the Manage Domains page again.

Here is a screen recording so it is easier to see:

I have also tried seeing if there was any pending invoice in the Billing section and there are none…

I have clearer cookies, tried a different browsed, logged out and back in and nothing.

I opened a ticket #3290777 4 days ago and still waiting for an answer. Can anyone please help?

Hello,

We appreciate your patience. I have responded to ticket #3290777 can you please respond via the ticket. So we can continue to assist you with this matter.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.