Can't log into your Cloudflare account to Authenticate cloudflared

I created a Cloudflare zero trust account to make a tunnel for my servers, then I followed the setup:
I got to the point where I need to Authenticate cloudflared
$ cloudflared tunnel login
this is the output

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

Try the new cross-platform PowerShell https://aka.ms/pscore6

PS C:\Users\User> Set-Location \Users\User\.cloudflared
PS C:\Users\User\.cloudflared> cloudflared cloudflared tunnel login
2022-03-22T11:44:12Z ERR Configuration file C:\Users\User\.cloudflared\config.yml was empty
2022-03-22T11:44:12Z INF Thank you for trying Cloudflare Tunnel. Doing so, without a Cloudflare account, is a quick way to experiment and try it out. However, be aware that these account-less Tunnels have no uptime guarantee. If you intend to use Tunnels in production you should use a pre-created named tunnel by following: https://developers.cloudflare.com/cloudflare-one/connections/connect-apps
2022-03-22T11:44:12Z INF Requesting new quick Tunnel on trycloudflare.com...
2022-03-22T11:44:16Z INF +--------------------------------------------------------------------------------------------+
2022-03-22T11:44:16Z INF |  Your quick Tunnel has been created! Visit it at (it may take some time to be reachable):  |
2022-03-22T11:44:16Z INF |  https://manchester-effect-follow-completed.trycloudflare.com                              |
2022-03-22T11:44:16Z INF +--------------------------------------------------------------------------------------------+
2022-03-22T11:44:16Z INF Cannot determine default configuration path. No file [config.yml config.yaml] in [~/.cloudflared ~/.cloudflare-warp ~/cloudflare-warp]
2022-03-22T11:44:16Z INF Version 2022.3.3
2022-03-22T11:44:16Z INF GOOS: windows, GOVersion: go1.17.5, GoArch: amd64
2022-03-22T11:44:16Z INF Settings: map[protocol:quic]
2022-03-22T11:44:16Z INF cloudflared will not automatically update on Windows systems.
2022-03-22T11:44:16Z INF Generated Connector ID: f593c341-60d2-40c4-b22e-aace5d87f0a4
2022-03-22T11:44:17Z INF Initial protocol quic
2022-03-22T11:44:17Z INF Starting metrics server on 127.0.0.1:55405/metrics
2022-03-22T11:44:17Z INF cloudflared does not support loading the system root certificate pool on Windows. Please use --origin-ca-pool <PATH> to specify the path to the certificate pool
2022-03-22T11:44:18Z INF Connection 9e3d5734-dc99-43a8-b738-6551a8acb427 registered connIndex=0 location=AMS
2022-03-22T11:44:18Z INF Connection 15ec43fc-d134-4f45-8a85-d12033f06f1a registered connIndex=1 location=LHR
2022-03-22T11:44:19Z INF Connection 9c242a18-18a5-409e-8fda-19931a1282af registered connIndex=2 location=AMS
2022-03-22T11:44:20Z INF Connection 8d92687d-d303-4dd1-a56f-5a69c1cacc18 registered connIndex=3 location=LHR

I am not sure is what I need to do? configure the .yml file?
How do i Create a an account certificate, the cert.pem file , in the default cloudflared directory .

Thanks for helping out :slight_smile:

It seems like you had a typo in your first step:

cloudflared cloudflared tunnel login

should had been

cloudflared tunnel login
2 Likes


:thinking: :bangbang:
Thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.