Can't Install Wordpress update

Hello

I have a Wordpress site on go daddy and I followed a tutorial to move it to cloudflare and improve the speed.
I recently had an issue trying to update some plugins and I fixed it by setting a rule to bypass cache on wp-admin* folder.
Today I want to update to the latest wordpress version but I can’t and I don’t know how to do it.

Could anyone please help me to be able to update that.
Otherwise I think that uploading all Wordpress files via FTP could be a solution but that can take longer than just clicking on the Update Wordpress version button.

Thanks in advance for the help

You shouldn’t have to set bypass cache for wp-admin unless you did something else in Page Rules to override default caching settings.

Do you have any other Page Rules?

What specifically is the issue when you attempt an update? Is there an error message?

Hi

I have 3 page rules:

  1. Always use HTTPS
  2. Cache everything under wp-content/uploads
  3. bypass wp-admin*

I got a HTTP 522 error when trying to update my site to the latest wordpress version

You really don’t need to Cache Everything under wp-content/uploads, as almost everything there is static and is cached by default. You also don’t need Always Use HTTPS, as you can already set that in the Crypto tab. And, as I mentioned before, there’s not much need to bypass cache for wp-admin, as the important stuff isn’t cached by default.

So that leaves you with a 522:

2 Likes

Thanks for your advice

I noticed that I have the always use https on the crypto tab so I removed the rule.
Somehow it worked with the bypass, i’ll remove that and wait for a new update from wordpress to see if it works.

I moved to cloudflare looking to improve my website’s performance and I followed a tutorial online.
I am working on a homepage redesign to get a better page speed score.
Yesterday I was looking for solutions to my “installing updates” problem and found this link: https://onlinemediamasters.com/cloudflare-settings-for-wordpress/

Any thoughts ?

Thanks again !

This topic was automatically closed after 30 days. New replies are no longer allowed.