Can't install warp Debian 12

brent@dell-3583:~$ sudo apt-get update && sudo apt-get install cloudflare-warp
Hit:1 http://security.debian.org/debian-security testing-security InRelease
Hit:2 https://downloads.1password.com/linux/debian/amd64 stable InRelease                                         
Hit:3 http://packages.microsoft.com/repos/code stable InRelease                                                   
Hit:4 http://deb.debian.org/debian testing InRelease                
Ign:5 https://pkg.cloudflareclient.com trixie InRelease
Err:6 https://pkg.cloudflareclient.com trixie Release
  404  Not Found [IP: 2606:4700::6813:ec18 443]
Reading package lists... Done
E: The repository 'https://pkg.cloudflareclient.com trixie Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Trixie is Debian 13. You can probably change the source file to be bookworm instead and it should work.

2 Likes

I didn’t even catch the Trixie part. I’m on testing which explains that. Thanks.