Cant install cloudflared on raspberry pi. It was working until 2024-01-01 then stopped suddenly. Now I cant install or re-install cloudflared

I originally installed a Zero Trust tunnel on a Raspberry pi in December 2022 running Bullseye OS and it was working ok until 2024-01-01 when the tunnel suddenly stopped working. I tried to reinstall cloudflared via the dashboard but I get this error:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
100 15.9M 100 15.9M 0 0 3156k 0 0:00:05 0:00:05 --:–:-- 5178k
(Reading database … 144813 files and directories currently installed.)
Preparing to unpack cloudflared.deb …
Unpacking cloudflared (2024.1.1) over (2024.1.1) …
Setting up cloudflared (2024.1.1) …
Processing triggers for man-db (2.11.2-2) …
2024-01-10T22:08:01Z INF Using Systemd
systemctl [start cloudflared.service] returned with error code exit status 1 due to: Job for cloudflared.service failed because the control process exited with error code.
See “systemctl status cloudflared.service” and “journalctl -xeu cloudflared.service” for details.

I then received an unexpected email from Cloudflare on 2024-01-04 to tell me to change my NameServers on my registrar which I have done. But I still get the same errors installing cloudflared.

I have tried uninstalling Cloudflared and reinstalling Cloudflared on other raspberry pi’s, differnet OS’s but still no good. I have searched for days but I get the same answer…follow the procedure in the ‘Setup a Tunnel Through the Dashboard’ which I have followed countless times. I feel i am at a dead end.

What else can I try??

Thank you