Can't get tunnels to work at all

Piloting as a VPN replacement for an org of around 100 employees.

Tunnels appear to do nothing. Nothing shows in the logs (literally blank). Steps I took:

  1. installed cloudflared on a Ubuntu physical host within the LAN and disabled the host firewall.
  2. installed WARP client on a Windows 11 box within the same LAN and connected.
  3. created a tunnel in the web dashboard, attached to a private network (CIDR matches the LAN), and gave it a public hostname (host1 . example . com) pointing to 22 on the LAN IP of the Ubuntu box.
  4. Tested SSH connection from Windows 11 to public hostname: failed
  5. Ping public hostname, resolves and replies (via ipv6).
  6. Added an application and “allow” policy for the same IP address.
  7. Tested SSH connection from Windows 11 to public hostname: failed
  8. Tried checking the tunnel log in the dashboard, the page just spins forever.
  9. Tried “cloudflared tail ” and nothing appears to be coming in. The log is blank maybe?

I tried the troubleshooting walkthrough. It asks if the tunnel is connecting to the gateway, and recommends reviewing the logs to determine that. But doesn’t specify what to look for. If it produces nothing in the log, does that indicate it’s not connecting? Or does nothing mean all is well? Unhelpful.

I also tried setting up an RDP tunnel for the Windows machine, then tried to RDP in from my phone, same issue. Nothing happens, nothing appears in the logs.

Appreciate any help. Thanks!

How are you testing SSH connection? What errors do you get from SSH?

Thanks for the reply. I’m using the OpenSSH client that ships with Windows. The error is:
ssh: connect to host host.example.com port 22: Connection timed out

Connecting to the local hostname instead of the public one works without issue.

You need to follow SSH · Cloudflare Zero Trust docs to use SSH with cloudflared.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.