Can't get plain domain name to work with google sites hosting

I have a website hosted at google sites ( I recently moved the domain name ( from google domains to cloudflare. I was able to get to work, but can NOT get the naked domain name to work. Here is my current setup:

Do you have any idea how to set this up correctly so both www and the plain domain name work with google sites hosting?

I was able to get it working using URL forwarding page rules (Configuring URL forwarding or redirects with Page Rules · Cloudflare Support docs)

This solved the immediate problem, but I’m still not sure if I solved it properly… The original www CNAME is currently set to DNS only, and when I set it to Proxied, the website breaks…

This is often caused by your SSL/TLS Mode being “Flexible” when it should be Full (Strict)

In the Cloudflare dashboard, under your domain, then “SSL/TLS” → Overview, you can change your SSL/TLS Mode. Magic link: isn’t a internet routable IP Address, it’s just used as a placeholder/for originless setups. How would that ever get to google?
If you wanted Google Sites to work, you would want to change that into a CNAME and add your apex/root domain to your Google Sites custom domains tab.

However, you’d get punished by search engines for duplicate content, so a redirect is the way to go. You can use that proxied IP like you did before, or AAAA 100:: for an originless setup that just uses Cloudflare Redirects.
You could use that same redirect rule you showed before. A small modification to keep the path would be a good idea as well, if you switch Type to Dynamic, you could use concat("", http.request.uri.path)


Yes, I have no set it to full strict:

The cname is working (, but the A record is still not working. I know it has in for the content, but my understanding is that doesn’t matter if it’s proxied…

For me, loads now

It wouldn’t matter as long as some Cloudflare feature (Page Rules, Dynamic Redirects, etc) match it and return a response. It wouldn’t go to Google Sites, and currently it’s just timing out:

Did you disable the single/dynamic redirect rule you had?

1 Like

Yes, I did disable the rule I had. I’m trying to solve this problem using ONLY DNS. Is that possible?

Doing a redirect using only DNS? No, why do you think you need to? You can just enable that rule again, and you can update it with the expression I gave you to so it keeps path as well.


Thank you! This seems to have solved it. Really appreciate your help!!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.