Can't get pass Cloudflare's 'verify human' check for ChatGTP

Hi there community,
I’m experiencing issues with the Cloudflare security applied to the ChatGTP site. I just can’t enter it anymore since days… Tried using different browsers, cleared cache etc. It just won’t let me in anymore.

In Chrome it just keeps asking me to ‘verify you are human’. Last time I checked, uhm that was this morning, yep, I’m still human :slight_smile:

In Firefox, Opera and Edge I end up in a very basic login page, doing nothing… (see attachment)

Tried my VPN, doesn’t work…

On my iPad it still works…

Can someone help me with finding a solution?
Thank you! Cheers!

Website owners can literally do what they want to do with their websites, that’s beyond the control of Cloudflare, even when the website owner choose to use Cloudflare.

In your situation, only ChatGPT can help you with what happens on their website, and you will therefore need to contact them for further assistance.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.