Can't get naked domain to work (without www)

I connected Cloudflare with a link shortening service like Bitly. The links seem to work only with www (www.example.com), but I’d like to use the naked domain (example.com/name). If I try to open the link without www, I get the 404 page.

I added an A record pointing to the link shortening server, and a CNAME record for www: Screenshot by Lightshot

I also created a forwarding rule: Screenshot by Lightshot

Can anybody help me fix this? Thank you!

They both ultimately redirect to the link shortener login page.

I noticed. Why is that?

Their support wasn’t very helpful, they said they only use www and what I’m asking needs to be done in CF.

Try setting the www CNAME to :grey: DNS Only (click on the :orange: to change).

Thanks for the suggestion. I did this, but no luck so far.

Is ‘www’ a CNAME? It behaves like an “A” record to a Linode server.

Yeah, it should be set as a CNAME (Screenshot by Lightshot)