Can't get https to work with own certificate

Hi, so I’m new to Cloudflare and setting up my SSL. I am using a third-party SSL provider that I’ve already set up and installed in my IIS. Since I’m not using Cloudflare’s SLL I disabled Universal SSL in the Crypto tab, but unfortunately I still can’t seem to access my https site. When I’m using SSL checker I get the error “No SSL certificates were found” and on Chrome I get the error message “ERR_SSL_VERSION_OR_CIPHER_MISMATCH.” I don’t where to start debugging the issue. Is this a Cloudflare issue or and IIS configuration issue? Any help is highly appreciated.

You can only do this if you have disabled proxying (switched the record to :grey:) otherwise you need to keep it enabled. Universal SSL refers to the certificates for your domain on Cloudflare’s proxies which are separate from your own certificate. You need both.

Thank you. I wasn’t aware that there was proxying built in. After I disabled it my https is now working.

Keep in mind, proxying is one of the central services. Without it you basically only use Cloudflare’s DNS infrastructure but everything else security and performance related wont function.

This topic was automatically closed after 31 days. New replies are no longer allowed.