Cant get access to cpanel

i tall started when I tried to switch from http to https, and then CLoudflare blocked my wp-admin sign in on Wordpress, and sent reset password email to some other address. Ends up in a Catch-22 and they will not respond directly to support.

Is your site properly configured for HTTPS now and can you share what error you’re seeing on wp-admin.

As for emails, please see this:

1 Like

Are you saying your Website wasn’t secured and wasn’t working over HTTPS before moving to Cloudflare? Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

If so, kindly consider below articles to make sure your WordPress website (domain) is working over HTTPS and the WordPress admin too:

Nevertheless, here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

How so?
May I ask do you see any blocked event at the Firewall Events tab of Cloudflare dashboard for your domain name?

Regarding the cPanel, may I ask how are you accessing the cPanel?
Are you trying to access via or or
If you were using sub-domain, was it covered in the SSL certificate?
Nevertheless, hopefully if you are using port, is it the default one 2083 (which is supported and compatible with Cloudflare at the link below) or rather some other?:

May I ask does the A cpanel DNS record exist at the DNS tab of Cloudflare dashboard for your domain name and is it set to :orange: or :grey:?

Otherwise, it could be some firewall or ModSecurity is blocking Cloudflare from accessing your website/cPanel? Please, consider looking at the below article and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

1 Like

I cannot get access to Cloudflare or cpanel to check any of the settings you suggest.

All I get is an automatic response to reset my password, which doesnt work and does not go into the spam folder.

Someone else – set this up then neglected to put my password as primary and they will not respond either.

This could be solved simply if you just put the correct email address in the cloudflare account: – {redacted} – I can prove ownership through a receipt to Godaddy. There is something seriously wrong with your automatic response system: I am not the only one who has had this problem – i

a friend says this is the problem. Again, when I went to wordpress, they said I was eligible to switch from Http to Htps on their tool section. I did this, and ever since then have been unable to sign in, reset my password, or access the cpanel. All you have to do is put the correct gmail address in my account at cloudflare – {redacted} Again, I can prove ownership. You can also use {redacted}, which is another address I can use. Note that the email and website are essentially the same name, which should give you a hint that I am the rightful owner of this site.

also note that I cannot sign up for a paid Cloudflare account; when I attempt to do so with my current websites, CLoudflare denies the request because they already manage the website – but with the wrong email address (see previoius messages). This is a catch-22, and again indicates a serious problem in your automatic responses. You have no idea how angry and frustrated I am about this.

1 Like

Thank you for the ticket number. I’ve escalated this in case if it could help a bit.

That’s really bad.
Have you tried reseting your Cloudflare account password?
Didn’t you receive an e-mail from Cloudflare?
Maybe as it seems to me your mentioned e-mails aren’t being associated with your domain?

I am sorry to hear this, but Cloudflare is not responsible for this so far as it seems to me.

We cannot do it “just like that”.

Please, kindly and patiently wait for the next 24hours as someone from Cloudflare team will respond to you(r) and your ticket where you could verify this further and resolve the issue.

  • it could be that it’s the timezone difference and weekend …

Next, your MX record saying:
0 x.x.x.218 (no glue)

Furthermore, I see the A mail DNS record is also proxied and set to :orange:, instead of being set to :grey: (DNS-only).


Also you are using a CNAME setup.

Kindly, I would advise you and suggest to:

  1. Temporary enable the Pause Cloudflare for this site option from the Cloudflare dashboard or switch all the DNS records from :orange: to :grey:.
  2. Wait for 10 minutes.
  3. Then try again to reset your password.

Kindly, if is your domain name, consider managing your domain DNS record at Cloudflare dashboard by looking at the below article to fix this issue and make sure your server is sending and receiving e-mails propperly:

I can access the cPanel page, but by not knowing credentials cannot enter it further visiting

May I ask are using WHM too?
Have you tried contacting your hosting provider to change a password for your username?
Either, usually we can change the cPanel password by logging into the Web hosting interface (for example WHMCS by the hosting provider).

1 Like

We will only send a pw reset email to the address that owns the account. Some other seems rather random and that’s not how it works.

I’d check your email accounts to see if you can locate the email you used for the zone, some other ideas here


appreciate that there have been more responses. I can now access the cpanel, but still have not been able to get the login to work. I will review again everything you have written. I think it is some wordpress/cloudfare compatibility issue. this seems close, and perhaps I didnt do it right because it is still not working. THis was a similar issue, but doesnt seem to work either;


wp-admin page is not allowing me to login, it is not showing me the login prompt, It is just showing coming soon page. It happened after enabling Cloudflare free SSL.

Here is what I have done:
1)Created Cloudflare account and added site.
2) Selected free SSL of type flexible
3)Added page rule to always use https
4)Installed Cloudflare and Cloudflare flexible SSL plugins on Wordpress
5)Connected to cloudlfare account using Global Key in Wordpress Plugin
6)Not Changed Wordpress Address (URL) to https, but changed Site Address (URL) to https under Settings → General in wordpress.
7)Changed DNS names in cpanel to the DNS names given by Cloudflare

Now, I end up with this situation. Can one one help me what to do now and how to fix this?

Nov '18

I believe that Step 6 is the problem. Flexible SSL connects to your server with HTTP, but Wordpress is telling it to come back on HTTPS. Try changing that Site Address back to HTTP.

Installed the cloudflare Fleixible SSL plug-in, still doesnt work.

Note that I cannot get to the Cloudflare dashboard becuase they wont let me sign in because I don’t have the right password and they send the password reset somewhere else…

Perhaps you can send me a reset password tthat works? [email protected]

(I have an account under a [email protected] email, but that also wont let me sign in because I don’t have account because I cant establish an account because the reset password is wrong… This is a catch-22

At this point, I think your best course of action is to set your domain’s name servers back to the default GoDaddy ones and get everything back up and running there. With HTTPS.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

We do not see the email with which the ticket was raised as part of Cloudflare account and hence cannot give details to that email. If you think another email is using the Cloudflare account and you do not remember, you can move your domains to another account by making Name Server changes at your registrar since you do have access to the same.

Please let us know if this helps.