Can't get 301 redirect to wok

No matter what I do, I can’t get a 301 redirect rule to work. I’ve attached images of my config and would appreciate any help.

I get an error every time. I’ve been bashing my head against this wall for hours.


Thank you for asking.

When I open your website I got this so far - Google Cloud Platform or Firebase? :thinking:

It’s a 503 error so far coming from the origin host/server.

Does anything change when you temporary switch the IPs to (shouldn’t, but …)

Furthermore, I can see SSL is set to Flexible, which might also cause issues as already described at the article from below :thinking:

Kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:


Neither. The destination I plan to use eventually is a shopify URL, but right now I’m forwarding to a simple hostgator domain. I’ve also tried redirecting to various other URLs… nothing works.

I’ve tried, but will again. Hold up 15 secs.

Yeah, set to now. No joy.

May I ask if the domain was connected since before with Shopify maybe?

My understanding was that for a simple redirect, flexible is best. But I’ve also tried unsecure (off) - didn’t help.

It was connected to shopify in the past!!! Why would that matter?

1 Like

Before moving to Cloudflare, was your Website working over HTTPS connection?

1 Like

Okay, thank you for feedback.

I am afraid that could be the issue then.

1 Like

So here’s what happened on my end.

  1. Domain was configured to shopify, with ssl.
  2. I spent like 2 weeks trying to configure a 301 redirect via my registrar, with no success.
  3. I registered with Cloudflare, yesterday.

Why would a past connection to shopify with ssl matter?

1 Like

Shopify haven’t properly deprovisioned your domain from their platform so whenever you proxy it on Cloudflare, their setup has a higher priority than yours so the traffic ends up going to them & you get the Shopify error page.


@kianh: That explains why the favicon that shows up is from the shopify store!

Is there a way to fix this? Or do we know how long it’ll take to time out?

Actually, I can go manually remove the domain from shopify. Hold up

1 Like

As @KianNH mentioned, there might be some issue or domain “stuck”.

Below article describes more in detail about this issue, if that’s your case too:

Kindly, may I ask you if you could use the tool called “Liberate the Hostname” from the article below:

Cool, great! :slight_smile:


Alright, I’ve removed the domain from shopify’s domain interface, and am adding the dns records for liberate the hostname now.

1 Like

I’ve successfully “liberated” the domain and returned the previous A records. So far no luck - still failing.

Actually, I just tried to load the domain from TOR to remove any caching shenanigans on my end, and I got a 522 Cloudflare error page… that’s new.

I can confirm, now I also got it:

Regarding Cloudflare 522 error, may I suggest you to look into below article to troubleshoot the issue (if already not yet):

My best guess, you should now try changing the SSL/TLS settings as mentioned before to Full (Strict) if you have a valid SSL installed at your origin host/server? :thinking:

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

As there might be some firewall, furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

I am attempting to redirect to a specific page in my shopify store. Do you have any idea what I should do?

Okay, may I just ask if you’re going to continue using Shopify or?
Because as from what I understand, you’ve disconnected your domain from them now and using manually/individually your domain with Cloudflare?

I am not so much familiar Shopify features and it’s interface.

What I could find out so far for what I believe could help you with it:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.