Cant find where my site redirect from non www to www


#1

My Wordpress blog redirects a 301 from non-www to www. That is extremely slow and takes something like 2.5 seconds everytime. So I started investigating the matter and I just can’t find where it is configured.

  1. In the site´s root .htaccess file I don´t see any rewrite rule,
  2. Also, there is no page rule configured inside Cloudflare.

Can you please help me find the reason for the redirection?
Thank you :slight_smile:


#2

Do you have the orange cloud enabled for your DNS records in your Cloudflare dashboard? If so, you can add a page rule:

https://mysite.com/*
Forwarding URL: https://www.mysite.com/$1

If you also enable “Always use HTTPS”, it will automatically redirect http://.mysite.com to https://.mysite.com. This only works though if you send traffic through Cloudflare (orange cloud in the DNS tab).

If you redirect this way, you can remove the 301 redirect with your host. How you do that depends on your host; it may be worth reaching out to them for assistance.


#3

thank you @StuartMorrisAU. I´ll try this tonight at home and see if that helps me reduce the slow redirection i`m suffering from. I´ll get back with more information later.


#4

Thank you, Stuart. That was the solution. The page rule made my site load fast, bypassing the redirect that cost so much.

But in more details, I can say that the redirect was caused by the Wordpress itself since the site URL is configured inside the blog options, which was the reason for this redirection.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.