Can't find "Always Use HTTPS" in Page Rules


#1

I just added a new domain to my Cloudflare account and notice that there is no “Always Use HTTPs” setting in Page Rules. I can still find it on my older domains. Does Cloudflare not provide this feature to new domains any more?


#2

The “Always Use HTTPS” option will only appear if your zone has an active SSL certificate associated with it on Cloudflare.

So you will have to wait a little bit till the certificate is issued and activated.


#3

Thank you Martin. I see under ‘Crypto’ that my certificate is still in the process of getting issued. That solves it. Appreciate your help.


#4

My certificate is issued. Website is working over https but still no option “Always use HTTPS” at page rules. How long do I need to wait after the certificate issued.


#5

That’s strange. It took some time for my certificate to be issued. But as soon as it got done, I could immediately see the ‘Always use HTTPs’ option.

Website is working over https

Can you elaborate on this?


#6

I was waiting for about 30 minutes and the option appeared .


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.