Can't enable Workers KV for subdomain in new workers dashboard

in the new workers dashboard, I got this message:

Workers KV is currently not available for

why? do I have to upgrade to a paid plan to use workers KV? I’m asking because docs mention nothing about that.

Workers KV

Store application data in the Cloudflare network and access your key-value pairs from Workers. Learn more

this link redirects to… , which has a sign in with google button, and it also doesn’t work, returns a Google http error code page.

403. That’s an error.

Error: org_internal


You can email the developer of this application at: [email protected]

This client is restricted to users within its organization.

…same thing happens when clicking on the “Documentation” tab in the new workers dashboard.

1 Like

Not sure if this is an inconsistency since I’ve paid for workers before the release, but I am available to use KV on my subdomain. I did test out canceling my workers subscription and the KV tab went away, so it seems like it’s currently tied to the $5/month payment for workers.

Docs state:

Your $5 Workers monthly base charge includes 1 GB of Worker KV storage and 10 million Worker KV reads per month.

Beyond that, you are billed $0.50 per GB-Month of additional storage and $0.50 per million additional reads.


I currently have a free Cloudflare account. I did not sign up for the $5/mo. workers feature. I can deploy workers, but when I try to create a namespace for Worker KV following these instructions I get this error:

  "result": null,
  "success": false,
  "errors": [
      "code": 10026,
      "message": "your account is not permitted to use this method"
  "messages": []
1 Like

For KV a $5 plan is required.


Your $5 Workers monthly base charge includes:

  • 1 GB of Worker KV storage
  • 10 million Worker KV reads per month
  • 1 million Worker KV writes per month
  • 1 million Worker KV deletes per month
  • 1 million Worker KV list operations per month

Additional KV operations are priced as follows:

  • $0.50 per GB of additional Worker KV storage per month
  • $0.50 per million additional Worker KV reads
  • $5.00 per million additional Worker KV writes
  • $5.00 per million additional Worker KV deletes
  • $5.00 per million additional Worker KV list operations
1 Like

Hm, a bit worrying that pricing keeps creeping.

The write, delete and list operations can acquire costs very quickly and will limit the scope of suitable apps.

To minimize KV cost, I store the most in global variables, with a ttl on those variable.

Problem is, globals only persist on the current worker. Try reloading the browser fully to see what I mean, you’ll get at least 3 diffent workers back.

About the global persisting on each worker it clear. But using them in conjunction with KV (if possible) it is an alternative.

My use case there was a saving of 40% on KV requests.

Of course if the data from the DB is not dynamic, it makes a lot of sense. But then won’t cache work better?

Hi, I’m facing the same problem. I’ve signed up for the paid KV plan, but also not able to create the namespace. Did you manage to find a solution?

Do you see this on workers overview?

For anyone else landing here with this problem, you have to manually enable Cloudflare KV on your account. Go to your dashboard, click on “Workers” in the main navigation. Scroll to the bottom of the page (folks, really?!) and there you will see this:


Hey @stefl;

Yep, sorry about that! We’d noticed that the flow here is a little complex, and we’re working on making it easier, but those changes haven’t shipped yet. Sorry it was tough for you, and glad you got that sorted!


Hello @sklabnik , I upgraded my account Workers account but I still can’t access Workers KV. I signed up yesterday and I hoped it was just a delay.

I had already created a account and was using it for a while until I hit this KV restriction. What should I do?



Hi! I’m not sure, but the correct path forward is to file a ticket with support; it shouldn’t have taken any time at all, so something is wrong. They can help you out though!