Can't enable HTTP/2

Hi, i can’t enable HTTP/2 on my zone.

  • Trough the Dashboard, button is disabled and can’t be toggled.
  • Trough the API, it returns: "code":1015,"message":"Not allowed to edit setting for http2"

Thanks.

That’s why you get that error message, you can’t disable it.

It most likely is already enabled, can you post a screenshot?

Ok i think this is a bug; HTTP2 was disabled while the zone was on a PRO plan; zone has been since downgraded to a FREE plan and now, it can’t be enabled again, as that setting can be changed on a PRO+ plan only, perhaps the default for a FREE plan is enabled… :face_with_raised_eyebrow:

In that case you will have to open a support ticket -> support.cloudflare.com/requests/new

Yes, that’s disabled, you need to open a ticket.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

This indeed seems to be a bug. Domains on the free plan should not be able to disable this setting, but still should be able to have it activated.

I’ll follow up on your ticket.