Can't enable CloudFlare cache

Hi all,

Can anyone tell me what am I doing wrong? I can’t enable cache for my website. I create the Page rules under filters, but when I check the site headers, there is absolutely nothing there indicating that the cache is active (see the images).

My site is www.dentalspa.co.rs

Thanks in advance!

Regards,
Vladimir

The cache-control header is instructing Cloudflare not to cache your pages. You can either change the Cache Control header at your origin, or override it by adding a Edge Cache TTL setting to the same page rule where you have Cache Everything.

BTW, your third page rule will never work, because all requests there are contained in the second page rule. So if you want to have Rocket Loader on, you can either set it on the Dashboard > Speed tab, or add it to your second page rule, along with the Edge Cache TTL setting.

Thanks for the replay! I added a Edge Cache TTL setting but nothing is changed when I load the page in the browser. The headers are the same. Am I doing something wrong there? Here are the screenshoots:


nocache

As already stated, that third rule doesn’t do anything. You should get rid of the second rule, then add the Edge Cache TTL to your Rocket Loader/Cache Everything rule.

Still no luck. I deleted the second and added TTL into the remaining one. It doesn’t overide cache yet.

It looks like that fixed it.

2 Likes

Thanks!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.