Can't edit or create Wordpress post while proxied by Cloudflare

I’ve set up a Wordpress site and written 2 posts, and then added Cloudflare for SSL purposes. While proxied by Cloudflare, I can’t create a new post or edit the old ones.

  • I’ve tried creating a firewall rule to “allow” my IP address (and I see the rule working, still no dice)
  • I’ve created a page rule that skips the cache for all wp-admin/* activity

I can edit if I bypass Cloudflare by entering a hosts file edit on my laptop and directly connecting to the site via http.

The error I get is this: “Updating failed, you must be offline”

I see a lot of “Blocked: mixed content” in the stack trace.

Another thing I can do that works is turn off the “allways use https” button on my edge certificate setting and remove the https from the browser while editing.

What error shows up to you?

Moreover, do you use any caching plugin with WordPress like W3 Total Cache?

Also, what option have you selected for “Cache” at Cloudflare dashboard?
Cache Everything maybe? (either general or on a Page Rule)

Do you have an SSL certificate installed at your host/origin for your domain and sub-domain(s) (like www, etc.)?

Which SSL option have you got selected under SSL tab/settings page at Cloudflare dashboard for your domain?

Is the WordPress installed on HTTP or HTTPS? (check the HOME URL and SITE URL values)

Do you also use some plugin to redirect, like Really Simple SSL?

Should look like this if using W3 Total Cache with Cloudflare:

Maybe you have got Flexible SSL option selected and your WordPress was obviously installed on HTTP, that could be a reason why you see them.

Here is a good article about why Flexible SSL is not a “win-win”:

Could you check the steps in the below article?:

Trying changing proxy status to “DNS only” then edit the wordpress post

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.