Can't disable auto connect

We have some use cases where we need to disable WARP for periods of time. I’ve created a profile under “Settings->WARP Client” and “Auto connect” is disabled but it never stays disabled.

When I run “warp-cli get-pause-end” when it’s disabled, it returns:
“Pause ends in 18446744073709551615 seconds”

I haven’t been able to figure out a pattern for when it re-enables itself.

I’m running on macOS 13.4 and use WARP version 2023.3.460.0