Can't create Gateway rule

Hi, I have configured Argo Tunnel on my server pointing to my apps, and I want to add another layer of security. Basically I want to skip auth if connected to my Team’s Gateway through WARP, so I’ve followed this guide:

https://developers.cloudflare.com/cloudflare-one/identity/devices/require-gateway

The thing is I can’t select Gateway option when configuring rule. It says “no results found”:


Can someone help me please?

I am facing same issue 🥲

@user9885 is it working now ?