Can't connect wordpress to cloud flare

Hi

I have created a webpage using wordpress locally on my QNAP NAS Drive. so I can view it by my internal IP address (https://192.168.1.10:8081/wordpress)

I have a domain purchased out of cloud flare.cf - How do I map the webpage i created using wordpress to Cloudflare

I can use the global API key

Cloudflare can’t proxy that site because it’s not publicly accessible.

You could add that IP address to a domain at Cloudflare, but it has to be set to :grey:. Then you’ll still need to access it as http://example.com:8081/wordpress

so let me be more specific!
I do have a A Record on cloud flare DNS pointing to my NAS Drive - https://krstechnologies.cf:2053 where I created a basic webpage using html as test But i want to use the webpage created by wordpress as its much easier - How can it be done?

I tried by activating the plugin but wordpress on my gas drive said “Current domain does not match with Cloudflare or something like that” the domain on wordpress states my local IP 192.168.1.10

While port 2053 is a valid HTTPS port at Cloudflare, 8081 is not (for HTTPS or HTTP). You probably also have krstechnologies pointing at your home network’s outside (WAN) address.

The IP address you list is in private IP address space.

To sum up, the IP address and Port you listed can not go through Cloudflare. At best, you can only use DNS to resolve the hostname (:grey: setting in DNS).

Unless you can get that NAS to serve up that Wordpress site as it’s doing for that static page, Cloudflare won’t be able to reach it.

Is it possible for me to change wordpress to 2053? I just edited the database (oh-admin) to change the wp_options value to 2053 but doesn’t seem to work

without the above, if I chose the :grey: will it work?

Before you can use Cloudflare, you need to get that site up and running as desired. Cloudflare only enhances what’s publicly reachable. Wordpress isn’t a web server, so you can’t make Wordpress change your web server port. It’s up to the software running on your NAS.

With :grey:, your site will only work internally. I do this with some devices at my job to make my life easier by assigning a hostname to an internal IP address.

The wordpress website was running fine on 192.168.1.10:8081 but 8081 is not supported through cloud flare cloud proxy -
two options here

  1. I am happy to bypass cloud flare poxy and just use 8081
  2. How do i change 8081 to 2053 - I tried editing the phpdatabase (wp_options) to 2053 but now it doesn’t even load using private ip of 192.168.1.10:2053?

Ok figured out something now

If i type in https://192.168.1.10:2053/WordPress it works
if I type in https://mypublicip:2053/WordPress it works
But if i type in https://krstechnologies.cf:2053/WordPress it does NOT work?

I have disabled the cloud selector on Cloudflare so its not proxying anymore

any thoughts?

This topic was automatically closed after 31 days. New replies are no longer allowed.