Can't connect to WARP App with Cloudflare for Teams account

I can’t connect to WARP App with Cloudflare for Teams account.
When I attempt to connect, I get an error (screenshot attached). I have attempted this on both Android and Windows clients (Beta and regular).

failed

When checking the Teams dashboard, I see it succeeded:

I’ve uploaded the app logs to: https://pastebin.com/vEnmqqg6
When looking at the app logs, I see the following interesting lines:

1. 2021-10-05T19:28:51.883+03:00 | <--(48f6) 401 Unauthorized https://api.cloudflareclient.com/v0a2017/reg (4781ms)
...
2021-10-05T19:28:51.903+03:00 | class com.cloudflare.app.data.apierrorhandler.ApiException: null
2021-10-05T19:28:51.904+03:00 | TeamSignIn error com.cloudflare.app.data.apierrorhandler.ApiException
2021-10-05T19:28:51.906+03:00 | class com.cloudflare.app.data.apierrorhandler.ApiException: null
2021-10-05T19:28:53.266+03:00 | Teams login error dialog abort
2021-10-05T19:28:53.415+03:00 | Device name already registered or account not created

The dashboard also doesn’t show any connected devices.

Tried a few different solutions (Adding a bypass rule for device authentication, Windows + Android, Beta + Regular), and nothing worked. Anyone have any ideas?

Figured it out!
Turned out my it was a weird edge case in Device enrollment permissions that was blocking me (Which is weird, considering that it claims it allowed me to enroll).

2 Likes