Can't connect to local Minecraft server using cloudflare argo tunnels

I’m trying to create a local Minecraft Server and Want people who are not in my home-network to be able to connect to server. So I looked into it and found out about Cloudflare Argo tunnels. I followed their documentation but it didn’t work. I think everything is working up untill running tunnel. When I run “CloudFlared tunnel run minecraft” the command just doesn’t end (gets stuck in a loop or something) and I’m not able to connect to the server via the subdomain I assigned. The url in my config.yaml file in the .cloudflared directory is http://localhost:25565.

Is that the wrong url or do I have to wait for the dns for propagate?

Also once I run a tunnel how do I stop it? Do I have to shut down my computer or how does that work?

You have to setup a config.yml file, and in this file you have to set the tunnel details, along with the ingress rules

You have to start by making sure that the cloudflared daemon is on the latest version.
Then you have to setup your config to debug the tunnels, and examine the cloudflared.log file for errors.


Remember, always cloudflared tunnel --help command is your best friend
just a ctrl + z should stop the tunnel , if it is not configured to run as a service ( systemctl )


I would start with by Setting my log-level to debug , and the transport-log level to debug.

reload the configuration and run your tunnel, check for errors in the cloudflared log file.

you can file then a support ticket with Cloudflare Team.

2 Likes

Im wondering also how to solve it.
Want to make Minecraft server available from outside throughout tunel and can not make it running. any advice with config.yaml, please ?

1 Like