Can't Configure MX record

Hi everyone,
I have a domain connected to shopify through Cloudflare. Now in order to use webmail, I’ve bought shared hosting from Namecheap. I have configured my DNS as per their instruction but its not being propagated (i.e. may webmail is not working). Please see that attached if I’ve configured the DNS properly.

would really appreciate your help.

Your ‘mail’ entry needs to be set to :grey:, as a :orange: entry won’t proxy email (only web traffic).

The pictures you posted are of two different domains. Is the nctest domain supposed to be the mail server for babywala? If so…read on:

If your first picture’s IP addresses are the IP addresses of your current mail server, you will need to put those IP addresses in the second screen instead of the .159 ones

I’m sorry for not clarifying, the 1st image is from namecheap’s instruction where nctest is used as an example.

Ok, so if those are the correct IP addresses, then just :grey: your ‘mail’ entry.

I am able to reach your Webmail interface. It doesn’t redirect to HTTPS, so you may want to consider using your SSL/TLS settings to enable “Always Use HTTPS.”

Could you kindly guide me how do I change my SSL/TLS settings please?

I’ve found the SSL/TLS settings thank you,
could you tell me if my current settings are ok?

(Because my mailbox isn’t working yet)

Webmail can be :orange:, and www can probably be :orange: (it should be, as it’s probably why you’re using Cloudflare). I’m not sure about auto discover, but I recall it’s usually :orange:.

What’s not working with your mailbox?

Here’s a tool I use test mail delivery: https://www.wormly.com/test-smtp-server (enter your server’s IP address, and then your email address at your domain).

What’s not working with your mailbox?

I am not receiving any email.

Here’s a tool I use test mail delivery: https://www.wormly.com/test-smtp-server (enter your server’s IP address, and then your email address at your domain).

Resolving hostname…
Connecting…
Connection: opening to server216.web-hosting.com:25, timeout=300, options=array (
)
Connection: opened
SERVER -> CLIENT: 220-server216.web-hosting.com ESMTP Exim 4.91 #1 Sat, 27 Oct 2018 10:09:26 -0400
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
CLIENT -> SERVER: EHLO tools.wormly.com
SERVER -> CLIENT: 250-server216.web-hosting.com Hello tools.wormly.com [96.126.113.160]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
CLIENT -> SERVER: STARTTLS
SERVER -> CLIENT: 220 TLS go ahead
CLIENT -> SERVER: EHLO tools.wormly.com
SERVER -> CLIENT: 250-server216.web-hosting.com Hello tools.wormly.com [96.126.113.160]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250 HELP
CLIENT -> SERVER: MAIL FROM:
SERVER -> CLIENT: 250 OK
CLIENT -> SERVER: RCPT TO:
SERVER -> CLIENT: 451 Temporarily unable to process your email. Please try again later.
SMTP ERROR: RCPT TO command failed: 451 Temporarily unable to process your email. Please try again later.
CLIENT -> SERVER: QUIT
SERVER -> CLIENT: 221 server216.web-hosting.com closing connection
Connection: closed
2018-10-27 14:09:46 SMTP Error: The following recipients failed: [email protected]: Temporarily unable to process your email. Please try again later.
Message sending failed.

GAA! I just noticed…your MX record says ‘mail’. It should say your domain name. Edit that record and put ‘@’ (no quotes), or babywala.com.bd

2 Likes

Is it ok now?

Mostly. I’d still set www to :orange:. But for now, your mail should work. Try that mail test again.

It also looks like you don’t have a DNS record for the non-www version of your domain. I’m not sure how Shopify wants to handle this, but I’d add another CNAME, but for babywala.com.bd and also point it to shops.myshopify.com (You might have to add a Page Rule to redirect to www if this doesn’t work properly).

I’m sorry, it’s too technical for me to understand what you’re saying here.

[My webmail is working fine now, can’t thank you enough]

1 Like

Well…as long as everything is working for you, you’re all set.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.