Cant change nameserver to cloudflare from one.com through punktum.dk

After what i have understood, when i want to change nameserver i need to change it through punktum dk instead of one com.

but when i try to do it it says this error:
billede

And when i contacted their support, they said it was not setup correctly on cloudflare’s part. But i cant find that i have missed something in the tutorial. I have disabled dnssec and checked that dns records are the same, which is none. But i cant seem to change it.

Have i missed something?

That is correct, name servers must (normally) be updated through the domain registrar.

For .DK domains though, that change would indeed need to be handled through Punktum.dk (formerly DK Hostmaster).

Can you share your domain?

yeah sure, sry i forgot.

lassenweb.dk

No worries.

Can you please try (re-)selecting your intended plan?

https://dash.cloudflare.com/?to=/:account/:zone/select-plan

If you intend to be on the Free plan, just try selecting Free again.

I cant press on the free plan, it just says current

Cloudflares name servers currently return code 5 (REFUSED), claiming that they are not authoritative for your domain.

The only situation where I am able to re-produce a such result, is when I stop at the plan selection page during onboarding, and then go further with Cloudflare - without actually having selected a plan at all.

The link from above is sending me the page where I can see Free like this:

Once I click anywhere in the field, it become marked like this:

Once I then click on the Continue button, Cloudflare starts to respond properly to DNS queries for the example domain that I’ve played around with.

If that doesn’t work for you, can you try going further from step #2 with the quick scan of DNS records, to import?

https://dash.cloudflare.com/?to=/:account/:zone/quick-scan

Try following from that point towards the end, without skipping anything.

I think i found my problem.

I didn’t find any dns to import, and i havent made any except for theese which were standard and i dont know how to make, because it wants an ipv4 address?

And then when i went to press continue it said this:
see next post

So i guess i found my problem but i dont know what dns records to import, because i havent made any?

Sry if i sound like a newbie. but i am

Here

Hmm, digging a little bit deeper on your domain, there is another issue regarding that.

You have an incorrect DNSSEC configuration at the moment, which turns your issue to become similar to the one I’ve previously mentioned in Edge Certificates (pending validation Txt) 24hr+ - #2 by DarkDeviL.

As such, Cloudflare doesn’t find any record(s) to import, as the cryptographic DNSSEC signatures do not verify properly.

Go to Punktum.dk (or DK Hostmaster) Selvbetjening:

DK Hostmaster selvbetjening - lassenweb.dk

Punktum dk selvbetjening - lassenweb.dk

Scroll down to the “DNSSEC-service”:

You should here have at least one DNSSEC key, with the same information 2371 - ECDSAP256SHA256 as indicated here.

However, that DNSSEC key would say either “:red_circle: Fejl” or “:red_circle: Error” instead, depending on your language selection.

Delete that DNSSEC key.

The DNS records generally come from your hosting provider, so if you would like to continue having your website hosted with One.com, but just move the DNS management (as it appears you’re trying to do) to Cloudflare, then the DNS record(s) would come from One.com, where you have your hosting.

Cloudflare does however try to import several well-known record(s), such as e.g. the A/AAAA records for your naked domain, and for www, and the MX records (related to inbound email traffic) during the onboarding process, to ease the work for you.

However, that seems not possible at the moment, due to the incorrect DNSSEC configuration mentioned above.

Once you have deleted that DNSSEC key, as mentioned above, wait at least 2 hours, and then try again.

No worries, and absolutely no need to be sorry. We can’t all be good at everything. :slight_smile:

1 Like

I have waited 3 hours now, and it still cant find any dns records to import

I just tried twice from my end, with your domain, and it managed to find two A records (naked domain, and www), as well as your MX records.

  1. Can you verify that you do not have any typo’s in the domain name you tried to add Cloudflare?

  2. If you have no typo, can you try using the “[Remove this site from Cloudflare]” procedure, to remove the current (but apparently broken) zone?

  3. After #2, try starting over with the “[Add site]” again, and make sure you follow the onboarding all the way from the beginning to the end.

Now, let us know if these steps (e.g. starting over) brought you any further?

Export the records from your existing provider and import them or create them manually as needed.

1 Like

Im sorry for all this trouble. :cold_face:

I had typed lassenweb.com

it works now

1 Like

Thank you so much for all the help

1 Like

No problem!

Happy to hear we’ve found the culprit to the issue!

You’re welcome. :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.