Can't add new hostname to existing tunnel

Hi community,
I hope someone can help me out here.
I have an existing tunnel with existing hostname to a .tk freenom domain.
Now im trying to add a new one but get this error:
Error: You cannot use this API for domains with a .cf, .ga, .gq, .ml, or .tk TLD (top-level domain). To configure the DNS settings for this domain, use the Cloudflare Dashboard.

I found some other questions on this about the api, but the thing is, im not using the api.
Im using the zero trust dashboard.
It has worked in the past, i’ve set up 4 other hostnames to the same domain also in the zero trust dashboard and it worked without any problem.

Any ideas why that error shows up?
I can also set up cnames in the dns dashboard for the same domain, just not in a tunnel in the zero trust dashboard.

Thanks in advance for any input

Zero trust dashboard is using the API to create DNS records. You can ignore those errors, but you’ll need to manually create the DNS records for the public hostnames.

I am facing a similar issue. The bigger problem is I have already created a dns record with said domains, I am still facing this issue

I am also facing this issue. Adding public hostnames worked a few months ago but now, it’s now giving this error. I have a .tk domain.