Can't access wp admin now that I have changed http to https

#1

Hi all,

I set up my website on cloudflare about an hour ago. I have received an email saying that everything is activated and also the overview section says Great news! Cloudflare is now protecting your site.

Now that I have changed the link from http to https in my wp-admin I am no longer able to log into my admin panel on wordpress.

Why could this be ?

Thanks,

Lee

#2

Hi @hiremytent,

Three questions!

  1. What is your domain?
  2. What is your SSL Mode set to in Cloudflare? - Flexible, Full or Full (Strict)
  3. What error do you get when trying to access WP-admin - screenshot is possible :slightly_smiling_face:
1 Like
#3

Hi

1, www.hiremytent.com
2, Full
3, !# File not found (404 error)

If you think what you’re looking for should be here, please contact the site owner.

#4

#5

Thanks. Looks like a GoDaddy issue, when I try to view any part of your site over HTTPS, I see the “Future Home of Something Cool…” error. There are some tips on fixing this below. Please just post back if you need further help.

#6

Hi I have tried all these steps and also tried deleting the wordpress installation and re installing wordpress for the domain. As soon as I change the wordpress url setting from http://www.hiremytent.com to https://www.hiremytent.com I am locked out of the admin account.

I have also spoken to go daddy and they say its a cloudflare issue : (

#7

The main site isn’t working, either.

My guess is your server doesn’t have SSL installed, but you’ve set Cloudflare to Full SSL. This requires a certificate on your server as well.

So did you try Flexible SSL, as the the article @domjh linked to suggested?

1 Like
#8

Yes I tried flexible that is what it is now set at.

#9

Everything works ok until i change the general site settings in wordpress admin to https then I am locked out of the account

#10

That setting needs to stay at HTTP. If you set it to HTTPS, then Wordpress is expecting Cloudflare to connect with HTTPS, which it can’t because your server doesn’t have SSL.

1 Like
#11

I am a bit confused with this then because my other website www.woodenteacups.com has been changed to https in the wp admin general settings section and that is working ok.

#12

What’s the Cloudflare SSL setting for woodenteacups? Flexible, or Full?

#13

its full

#14

its working now I changed it back to full

#15

Thanks for your help

2 Likes
closed #16

This topic was automatically closed after 30 days. New replies are no longer allowed.