Can't access wordpress site ecently activated cloudflare ssl

ssl
dns
wordpress

#1

I recently activated the cloudflare ssl for my wordpress site,
changed nameservers from google domains to cloudflare,
my wordpress site files is inside a subdirectory “public_html/MAIN/” and i had an .htaccess redirection file as per wordpress instructions. the site has been working fine for over a year.

as soon as the cloudflare was activated and DNS updated, i couldn’t access my site front end and back end.

can anyone help me or does anyone have similar situation with a solution/work around to it?

Thanks


#2

Can’t sign in to my account


#3

What is the error message?


#4

so the .htaccess which had my redirection for my main site to a subfolder was replaced by cloudflare. I had to delete the site from cloudflare and redirected everything back to google domains, then moved all my files to the public_html/ folder which i don’t really prefer, added cloudflare ssl again, i’m still able to access it but still waiting for the SSL to propagate, created certificates from cloudflare and installed in my server.

is there a way to put back my files back to the subfolder where i don’t see lots of clutter in my public_html/ folder?
I have quite a few subdomain folders in there


#5

So you had a configuration before that you liked but didn’t work. Now you have a configuration that works but you don’t like it. Cloudflare itself doesn’t care how your origin server is configured. If you packed all of your configuration into httpd.conf instead of .htaccess files Cloudflare wouldn’t be able to tell the difference. It just repeats whatever your origin server responds with unless you use page rules or something.
What about the old configuration didn’t work? Are you sure that Cloudflare caused it? If you disabled cloudflare’s CDN by setting it to :grey: instead of :orange: would it start working?
You said that redirection was replaced by Cloudflare. Did that break something? HTTP redirects are usually only generated by Cloudflare if you use page rules or “Always use HTTPS” or do something weird with web workers or set some other settings. Can you just undo that and let redirection continue to be taken care of by your origin server?


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.