Can't access Wordpress after activating Cloudflare

Hello everyone :slight_smile:

I have registered my website yesterday for Cloudflare but since then I can’t access my website’s dashboard (Wordpress) at

I get this error message: “ERR_TOO_MANY_REDIRECTS”

NOTE: I have updated the Cloudflare DNS to my domain

Also, I just noticed that since my website is on Cloudflare some pages of my website are broken!! The products pages also are now looking weird!

Can someone please help? I’m new to using Cloudflare so maybe I did something wrong or did not configure something?



Hi there. I’m guessing you’re on the Free plan and using Flexible SSL mode. If so, it’s common to get a redirect loop under this scenario with Wordpress. You might need to install this plugin to correct the issue

You’re probably wondering how to install a plugin if you can’t access wp-admin. You can put your site into ‘Development Mode’ which essentially disables all of Cloudflare services for your domain. This toggle is found on the Caching tab. You will need to access wp-admin using your standard URL (not https).

I’m not 100%, but this typically resolves the issue.

1 Like

Thanks for replying back Andy.Yes I’m on free for now because it is a new website.

I followed your suggestion of activating the “development mode” and tried to access WP without the https but unfortunately it is not working :frowning:

I thought this might be the case. Do you by chance have FTP/SFTP access to your origin server? You may need to install the plugin manually - I can walk you through it if you have FTP access. If not, I will think of Plan C :slight_smile:

Good Morning Andy,

I don’t use FTP much … most of the time I use File Manager from my cPanel to install plugins.

I have a question: Please, where do I find the necessary plugin in my Cloudflare account to install on my WP website?

Hello again :slight_smile: I’m trying to troubleshoot this but I’m having a hard time reproducing your issue.

Let’s try a different approach. I am still thinking that you need to install that plugin I mentioned above, however I realize now that installing it manually is not an option because you have no way of activating it via wp-admin (because you can’t log in to wp-admin).

Please try this. On the Cloudflare dashboard navigate to the ‘Crypto’ tab and make the following changes:

  • Set SSL mode (at the top of the page) to ‘Off’
  • Set ‘Always use HTTPS’ to Off
  • Set ‘Automatic HTTPS Rewrites’ to Off

With those changes in place, open a new private tab in your browser (so there is no cache), and navigate to and let me know the results.

Edit: if you are able to access wp-admin after following the above steps, please install that plugin I mentioned, activate it, and then revert the changes above (turning them all back ‘On’) and see if you are still able to access wp-admin via https.

Dear Andy,

sorry for my late reply, I wasn’t online for a few days.

Thanks a lot for your kind help. Meanwhile I had sent a ticket to support who replied back to me with some explanations after visiting my website. It seems that the issue I was having was due to SSL that I had already installed on my site from origin. So the solution in my case was to set SSL in Cloudflare to Full or Full (strict) instead of Flexible SSL which is set as default.

If someone else in the forum is having such issues I hope that this topic will help them solve their own issue whether with what Andy has suggested or by configuring the SSL in Cloudflare :wink:

Thanks again Andy for your kind help and have an excellent week ahead!



Glad you got it sorted out! :grinning:

HI thanks a lot, I was panicking when I started to get the too many redirects message from every browser that I tried to access my site from. It was after I deactivated the Cloudflare Flexible SSL plugin in my wordpress admin. I wanted to re-install the plugin. But then I couldnt get back into my site or admin to re-install it. When I saw your message about changing SSL to Full in the Crypto section of Cloudflare, it opened up my access back to my admin where I was able to re-install the Cloudflare Flexible SSL plugin. Then I was able to put the SLL back to Flexible in Cloudflare after activating the Cloudflare Flexible SSL plugin.



Wonderful! I’m glad that this thread has helped you solve your issue and with your detailed post I’m sure it will help someone else :slight_smile: That’s the advantage of a Forum!

Have a great day :wink:



You guys helped me soooo much!!! Thank you all!

1 Like

//Using this code you can activate your plugin from the functions.php
function activate_plugin_via_php() {
$active_plugins = get_option( ‘active_plugins’ );
array_push($active_plugins, ‘Cloudflare/Cloudflare.php’); /* Here just replace unyson plugin directory and plugin file*/
update_option( ‘active_plugins’, $active_plugins );
add_action( ‘init’, ‘activate_plugin_via_php’ );

Insert this to functions, and it will help activate the plugin again, if you deactivated it

1 Like


I had the same problem and found a great solution that works every time like a charm.
In cPanel go to phpMyAdmin and click on wp_options. At the very top click on 1: siteurl and 2: home.
Remove the s in https for each url. Reload the wp admin url and it should load no problem. Then you can install Cloudflare Flexible SSL. I have not had to change the urls back to https in phpMyAdmin after doing this. So far it`s worked great, and solved the issue with every domain that had a redirection loop problem.

Sincere Regards,
JD Sites

1 Like

Hello guys, thank you for solving this ticket. Here are those steps i performed for a client’s site of mine Candle Cake i actually was using Let’s Encrypt in my Cpanel and then i added the site to Cloudflare.

I added a plugin which was redirecting all http to https but looks like that plugin vas the issue. So, after reading this post/ticket i came to the point that after adding the site to Cloudflare i should use this plugin which auto solve all the issues on autopilot --> Cloudflare Flexible SSL

< snipped >

many many thanks for solve this query easily, i was very confused about this issue, all members of this forum are very friendly, thanks again from arun sharma < snipped >

thank you bro