Can't access to my website, DNS problem?


I started using Cloudflare as CND yesterday. I followed every step and change my hosting name server to the ones that Cloudflare said.

But, suddenly today I was getting a 522 error. I contacted my VPS support team to know what’s happening (I contacted my registar domain too)

It seems that my domain is pointing to this ip:

It seems that’s the problem. And Idk how to deal with that.

Even when Cloudflare just says that I have to change my nameservers. I don’t know what to do… if just add an A record or what…

My website is:

Also, using host -t A command with my website shows that the IP address of my website is and (A records)

I have changed the DNS setting on my registar domain settings (Dynadot) do I have to delete the nameservers and do everything as well with my VPS (Digital Ocean).

PS - I contacted both, and the support team didn’t know what to do. DO told me that my A record isn’t registered. And Dynadot told me that my nameserver were configured to work with Cloudflare.

Thats not the problem, that is how Cloudflare works. Please read the documentation at

A 522 is explained in detailed at It would seem your webserver is not responding, check that everything is running and you have a valid HTTPS certificate in place on your server.

Ok that’s how it works. But why my VPS and registar still says that’s the issue?

Because everything was working until yersterday.

My HTTPS certificate it’s fine.

Because they are incompetent? :smile: I have no idea. A 522 is described in the linked article and also which steps you should take to fix it. Also you need to check the steps I already outlined.

Do you feel comfortable to reveal your server IP address here?

Well. I don’t have any firewall on my server.


My VPS support team takes too long to reply… So, I don’t want to rely on them.

If this issue can be fixed thru the server console would be great.

Not problem with iptables, not firewall installed. No .htaccess file existing.

Hmm, your server is responding on both HTTP and HTTPS and appears to be properly configured.

Are you sure your DNS records are in order? Can you post a screenshot? What about the SSL mode? Which one did you choose? Though the latter shouldnt make much of a difference.

You might have to submit a support ticket with Cloudflare.

Should I take the screenshot of my registar settings or my VPS settings (Yup, that confuses me as well haha).

I’ll send you both Give me a few secs.

Anyways, I know my DNS are ok because it seems to be OK with intoDNS

Cloudflare says SSL: Full.

But now I think about it… I have a SSL certificate installed in my VPS (Let’s Encrypt).

Only the DNS records at Cloudflare matter.

The certificate on your server is all right and should stay that way. You could even switch to Full strict instead of Full and it would be more secure, but that would not fix the issue at hand.

That explains it. Your site only runs on 165, right? In that case remove A records #2 and #3.

1 Like

Ok, on it. If it doesn’t work I’ll be here posting things again :slight_smile:

Ok, now I feel like an idiot hahahahahahahahahahhaha. It works! Thank you!

Can I know what was actually the problem? It was working well 2 days ago and then suddenly stopped yesterday. So, I didn’t even thought than that could be the solution.

The issue was that you had three IP addresses and Cloudflare proxied that in a round-robin way to these addresses. Some requests went to your actual address, but two out of three to the other two.

Ohhhh I got it!

Yeah, those were my DNS ip Addresses from DigitalOcean. I understand everything now…

Glad we could sort it out :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.