Can't access site a SSL certificate uses unsupported protocol

When I access a domain I have added to cloudflare (rosso-caffe.co.uk) it come up with an error:

This site can’t provide a secure connection
rosso-caffe.co.uk uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

If I look at the edge certificates it says it has been deleted


but it won’t let me order a free basic certificate

Even if i set the Your SSL/TLS encryption mode to “off” the site still doesn’t work.

The site currently loads fine on HTTP → sitemeer.com/#rosso-caffe.co.uk

First question, did your site work fine on HTTPS before Cloudflare?

It’s a new site so it’s only been on cloudflare.

I’d pause Cloudflare for now and make sure it loads fine on HTTPS before you proceed with the Cloudflare setup.

I do assume you want SSL eventually right? If not, then it should already work with the current settings.

Yes, I want to use the SSL certificate that cloudflare provides but under status it says deleted and wont let me get a new one.

Then pause Cloudflare for now.

@matt99 I’d like to add that only the www subdomain is proxied at the moment. You should enable proxying :orange: for rosso-caffe.co.uk as well - after you’ve done what Sandro suggested :slightly_smiling_face:
rosso-caffe.co.uk. 101 IN A 205.XXX.XXX.XXX

ok, so I pause it but then how do i get an edge certificate from Cloudflare?

Step by step. First pausing, that’s done at the bottom right of the Overview screen.

ok, that’s done

All right, you have a proper certificate on your server. You can unpause now again.

Can you post a full page screenshot of your SSL page on Cloudflare?

That looks all right, is Universal SSL enabled at the bottom of https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates?

I’d disable it, wait about half an hour, and then re-enable it.

ok, I will try that. Thanks for your help

Just re-enabled universal SSL and unfortunately it’s still not issuing me a universal SSL certificate. Still says deleted next to the one thats there already.

In that case you’ll probably need to drag in support as they will have to manually fix this.

Open a support ticket and post the ticket number here. Keep in mind, it will be automatically closed, but you can reply twice to it to re-open it.

ok, thanks. ticket number is: 2278643