Cant access my wordpress site with www

hello,
after changing the nameservers from my provider to cloudflare im not able to access my site with www.

https://mysite.com works
https://www.mysite.com doesnt work

can someone help me fixing this.
thanks

Try this:

1 Like

thanks for that quick reply.

i tried to but its still not working

neither https://mydomain.com -> https://www.mydomain.com
nor https://mydomain.com/* -> https://www.mydomain.com/$1

:-/

That’s the opposite of what the tutorial instructs.

yes because it looks a bit more serious for customer in they see www.

i tried the other way around too now but that didnt help :-/

That’s all I can suggest given the limited info you’ve provided.

working domain: https://blikblok.de
not working domain https://www.blikblok.de

after setting the redirect rule i expected not to get an error saying:

This site can’t be reached

The webpage at https://www.blikblok.de/ might be temporarily down or it may have moved permanently to a new web address.
ERR_NAME_RESOLUTION_FAILED

screenshot would be an overkill i think because you would only see exactly what i wrote.
i also contacted my provider but they said they cant do anything at all since the nameserver were changed.

thanks a lot

Your host server isn’t properly configured for the ‘www’ version of your site.

Your provider’s response is lousy. They can do something, but choose not to. Or maybe they have no tech skills. Go ahead and set the ‘www’ to :grey: and make your host fix it. Or get a new host.

Or just follow the instructions in the tutorial I posted and not use ‘www’ for the canonical URL.

1 Like

i have no idea if their support staff is skilled or not :-/
changing the provider is a bit of a pain in a**, i have so many things there (DBs, Emails,…)
i have some other sites to on that provider and everything is workling fine. thats why im wondering that not even 1 topic about this issue is listed on their support forum, im using hosteurope.de.

i tried “Or just follow the instructions in the tutorial I posted and not use ‘www’ for the canonical URL” but that didnt work.

ive set the orange cloud the a gray cloud and i call my provider again. otherwise it seems i cant use cloudlare on this one… whats really strange to me is that the provider is a big one and i just cant believe that no other customer had that problem before.

thank you

That one definitely works as followed, since it doesn’t depend on your host for the ‘www’ to work. It will redirect the browser to the non-www site, which definitely works. If you want to set it up again, we can test it out.

1 Like

its still active, i didnt change anything.
we can test it.

this are the rule settings.

and here dns

That redirect is working.

hmmm strange and do you know why it isnt working in browser?

thanks

EDIT: i think i go a another way, this is just to many problems to start with. thank you for your help!