Cant access a site hosted on my server outside home

Hi,

First of all since i am new here, i cant paste images and more than 1 link, so i made a google document where i pasted all links and photos, just click here

I have a Chuwi Hi Box) with Open Media Vault 5, Docker and Portainer.

I have Wordpress installed and Nginx Proxy Manager that i installed following this tutorial . I would like to access my wordpress site (just a personal stuff, not for public) and some other stuff like Sonarr and other services i have installed in Portainer, outside of my home. Since i don’t have a domain i “bought” a free one from Freenom , word-omv.tk .

  • I installed Nginx Proxy Manager using this Stack in Portainer:

    version: “2”

    services:

    nginx-proxy-manager:

    image: jlesage/nginx-proxy-manager:latest

    container_name: nginx-proxy-manager-2

    network_mode: bridge

    environment:

    • USER_ID=998 #id de votre utilisateur

    • GROUP_ID=100 #gid de votre utilisateur

    • UMASK=022 #rwxr-xr-x

    • CLEAN_TMP_DIR=1 #All files in the /tmp directory are delete during the container startup

    • TZ=Europe/Lisbon

    volumes:

    • /srv/dev-disk-by-label-1TB/Config/nginx-proxy-stacks-2:/config

    • /srv/dev-disk-by-label-1TB/Config/nginx-proxy-stacks-2/data:/data

    • /srv/dev-disk-by-label-1TB/Config/nginx-proxy-stacks-2/letsencrypt:/etc/letsencrypt

    • /srv/dev-disk-by-label-1TB/Config/nginx-proxy-stacks-2/local:/etc/localtime:ro

    ports:

    • 84:8080 #84 is the Port used to serve HTTP requests 8080

    • 82:8181 #82 Port used to access the web interface of the application 8181

    • 4443:4443 #Port used to serve HTTPs requests

    restart: unless-stopped

PORTS 80, 81 and 443 are in use with other applications i have in Portainer

  • I register myself in Cloudflare, i pointed DNS servers from Cloudflare to freenom like in this picture

see photo in google document at the begining of this post

In Cloudflare i have this:

see photo in google document at the begining of this post

Except the wordpress.word-omv.tk CNAME record that i created, the others were “recognized” by Cloudflare automatically.

  • In Docker > Portainer > Nginx Proxy Manager i have this:

see photo in google document at the begining of this post

192.168.1.198:8099 is where i have Wordpress running and where in my network i can edit/see my Wordpress website

  • In Docker > Portainer > Nginx Proxy Manager Logs i have this:

    2020-07-02 17:31:30 0 [Note] InnoDB: Completed initialization of buffer pool,

    2020-07-02 17:31:30 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().,

    2020-07-02 17:31:30 0 [Note] InnoDB: 128 out of 128 rollback segments are active.,

    2020-07-02 17:31:30 0 [Note] InnoDB: Creating shared tablespace for temporary tables,

    2020-07-02 17:31:30 0 [Note] InnoDB: Setting file ‘./ibtmp1’ size to 12 MB. Physically writing the file full; Please wait …,

    2020-07-02 17:31:30 0 [Note] InnoDB: File ‘./ibtmp1’ size is now 12 MB.,

    2020-07-02 17:31:30 0 [Note] InnoDB: 10.3.23 started; log sequence number 1625466; transaction id 21,

    2020-07-02 17:31:30 0 [Note] InnoDB: Loading buffer pool(s) from /config/mysql/ib_buffer_pool,

    2020-07-02 17:31:30 0 [Note] InnoDB: Buffer pool(s) load completed at 200702 17:31:30,

    2020-07-02 17:31:30 0 [Note] Plugin ‘FEEDBACK’ is disabled.,

    2020-07-02 17:31:30 0 [Note] Server socket created on IP: ‘::’.,

    2020-07-02 17:31:30 0 [Note] Reading of all Master_info entries succeeded,

    2020-07-02 17:31:30 0 [Note] Added new Master_info ‘’ to hash table,

    2020-07-02 17:31:30 0 [Note] /usr/bin/mysqld: ready for connections.,

    Version: ‘10.3.23-MariaDB’ socket: ‘/run/mysqld/mysqld.sock’ port: 3306 MariaDB Server,

    [services.d] starting logrotate…,

    [services.d] starting app…,

    [app] starting Nginx Proxy Manager…,

    [logrotate] starting…,

    [services.d] done.,

    [7/2/2020] [5:31:36 PM] [Migrate ] › :information_source: info Current database version: none,

    [7/2/2020] [5:31:36 PM] [Migrate ] › :information_source: info [initial-schema] Migrating Up…,

    [7/2/2020] [5:31:36 PM] [Migrate ] › :information_source: info [initial-schema] auth Table created,

    [7/2/2020] [5:31:37 PM] [Migrate ] › :information_source: info [initial-schema] user Table created,

    [7/2/2020] [5:31:37 PM] [Migrate ] › :information_source: info [initial-schema] user_permission Table created,

    [7/2/2020] [5:31:38 PM] [Migrate ] › :information_source: info [initial-schema] proxy_host Table created,

    [7/2/2020] [5:31:38 PM] [Migrate ] › :information_source: info [initial-schema] redirection_host Table created,

    [7/2/2020] [5:31:38 PM] [Migrate ] › :information_source: info [initial-schema] dead_host Table created,

    [7/2/2020] [5:31:39 PM] [Migrate ] › :information_source: info [initial-schema] stream Table created,

    [7/2/2020] [5:31:39 PM] [Migrate ] › :information_source: info [initial-schema] access_list Table created,

    [7/2/2020] [5:31:39 PM] [Migrate ] › :information_source: info [initial-schema] certificate Table created,

    [7/2/2020] [5:31:40 PM] [Migrate ] › :information_source: info [initial-schema] access_list_auth Table created,

    [7/2/2020] [5:31:40 PM] [Migrate ] › :information_source: info [initial-schema] audit_log Table created,

    [7/2/2020] [5:31:40 PM] [Migrate ] › :information_source: info [websockets] Migrating Up…,

    [7/2/2020] [5:31:40 PM] [Migrate ] › :information_source: info [websockets] proxy_host Table altered,

    [7/2/2020] [5:31:40 PM] [Migrate ] › :information_source: info [forward_host] Migrating Up…,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [forward_host] proxy_host Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [http2_support] Migrating Up…,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [http2_support] proxy_host Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [http2_support] redirection_host Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [http2_support] dead_host Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [forward_scheme] Migrating Up…,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [forward_scheme] proxy_host Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [disabled] Migrating Up…,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [disabled] proxy_host Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [disabled] redirection_host Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [disabled] dead_host Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [disabled] stream Table altered,

    [7/2/2020] [5:31:41 PM] [Migrate ] › :information_source: info [custom_locations] Migrating Up…,

    [7/2/2020] [5:31:42 PM] [Migrate ] › :information_source: info [custom_locations] proxy_host Table altered,

    [7/2/2020] [5:31:42 PM] [Migrate ] › :information_source: info [hsts] Migrating Up…,

    [7/2/2020] [5:31:42 PM] [Migrate ] › :information_source: info [hsts] proxy_host Table altered,

    [7/2/2020] [5:31:42 PM] [Migrate ] › :information_source: info [hsts] redirection_host Table altered,

    [7/2/2020] [5:31:42 PM] [Migrate ] › :information_source: info [hsts] dead_host Table altered,

    [7/2/2020] [5:31:42 PM] [Migrate ] › :information_source: info [settings] Migrating Up…,

    [7/2/2020] [5:31:45 PM] [Migrate ] › :information_source: info [settings] setting Table created,

    [7/2/2020] [5:31:45 PM] [Migrate ] › :information_source: info [settings] Default settings added,

    [7/2/2020] [5:31:45 PM] [Migrate ] › :information_source: info [access_list_client] Migrating Up…,

    [7/2/2020] [5:31:46 PM] [Migrate ] › :information_source: info [access_list_client] access_list_client Table created,

    [7/2/2020] [5:31:46 PM] [Migrate ] › :information_source: info [access_list_client] access_list Table altered,

    [7/2/2020] [5:31:46 PM] [Migrate ] › :information_source: info [access_list_client_fix] Migrating Up…,

    [7/2/2020] [5:31:46 PM] [Migrate ] › :information_source: info [access_list_client_fix] access_list Table altered,

    [7/2/2020] [5:31:46 PM] [Setup ] › :information_source: info Creating a new JWT key pair…,

    [7/2/2020] [5:32:02 PM] [Setup ] › :information_source: info Wrote JWT key pair to config file: /opt/nginx-proxy-manager/config/production.json,

    [7/2/2020] [5:32:02 PM] [Setup ] › :warning: warning Restarting interface to apply new configuration,

    2020-07-02 17:32:02 9 [Warning] Aborted connection 9 to db: ‘nginxproxymanager’ user: ‘nginxproxymanager’ host: ‘localhost’ (Got an error reading communication packets),

    2020-07-02 17:32:02 10 [Warning] Aborted connection 10 to db: ‘nginxproxymanager’ user: ‘nginxproxymanager’ host: ‘localhost’ (Got an error reading communication packets),

    [app] starting Nginx Proxy Manager…,

    [7/2/2020] [5:32:06 PM] [Migrate ] › :information_source: info Current database version: 20200410143840,

    [7/2/2020] [5:32:06 PM] [Setup ] › :information_source: info Creating a new user: admin @example. com with password: changeme,

    [7/2/2020] [5:32:08 PM] [Setup ] › :information_source: info Initial setup completed,

    [7/2/2020] [5:32:08 PM] [IP Ranges] › :information_source: info Fetching IP Ranges from online services…,

    [7/2/2020] [5:32:08 PM] [IP Ranges] › :information_source: info Fetching https :// ip-ranges.amazonaws. com/ip-ranges.json,

    [7/2/2020] [5:32:08 PM] [IP Ranges] › :information_source: info Fetching https:/ /www. cloudflare. com /ips-v4,

    [7/2/2020] [5:32:08 PM] [IP Ranges] › :information_source: info Fetching https:/ /www.cloudflare. com/ips-v6,

    [7/2/2020] [5:32:08 PM] [SSL ] › :information_source: info Let’s Encrypt Renewal Timer initialized,

    [7/2/2020] [5:32:08 PM] [SSL ] › :information_source: info Renewing SSL certs close to expiry…,

    [7/2/2020] [5:32:08 PM] [IP Ranges] › :information_source: info IP Ranges Renewal Timer initialized,

    [7/2/2020] [5:32:08 PM] [Global ] › :information_source: info Backend PID 952 listening on port 3000 …,

    [7/2/2020] [5:32:12 PM] [Nginx ] › :information_source: info Reloading Nginx,

    [7/2/2020] [5:32:12 PM] [SSL ] › :information_source: info Renew Complete,

    [7/2/2020] [5:32:26 PM] [Express ] › :warning: warning invalid signature,

    [7/2/2020] [5:33:54 PM] [Express ] › :warning: warning invalid signature,

    QueryBuilder#allowEager method is deprecated. You should use allowGraph instead. allowEager method will be removed in 3.0,

    QueryBuilder#eager method is deprecated. You should use the withGraphFetched method instead. eager method will be removed in 3.0,

    QueryBuilder#omit is deprecated. This method will be removed in version 3.0,

    [7/2/2020] [5:35:37 PM] [Nginx ] › :information_source: info Reloading Nginx,

    [7/2/2020] [5:35:38 PM] [SSL ] › :information_source: info Requesting Let’sEncrypt certificates for Cert #1: wordpress.word-omv.tk,

    [7/2/2020] [5:37:13 PM] [Nginx ] › :information_source: info Reloading Nginx,

    [7/2/2020] [5:37:13 PM] [Express ] › :warning: warning Command failed: /usr/bin/certbot certonly --non-interactive --config “/etc/letsencrypt.ini” --cert-name “npm-1” --agree-tos --email “MY_EMAIL” --preferred-challenges “dns,http” --webroot --domains “wordpress.word-omv.tk” ,

    Saving debug log to /config/log/letsencrypt/letsencrypt.log,

    Plugins selected: Authenticator webroot, Installer None,

    Obtaining a new certificate,

    Performing the following challenges:,

    http-01 challenge for wordpress.word-omv.tk,

    Using the webroot path /data/letsencrypt-acme-challenge for all unmatched domains.,

    Waiting for verification…,

    Cleaning up challenges,

    Failed authorization procedure. wordpress.word-omv.tk (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http : //wordpress.word-omv. tk/.well-known/acme-challenge/5jAOAFNFa3sB2PTTiBqLihWhu_vG60GvlgleVHLIWG0: Timeout after connect (your server may be slow or overloaded),

    ,

I have reinstalled Nginx Proxy manager many times, restarted everything but it never works and i have no idea why…. Most likely i´m missing some basic stuff but no idea what…

Can someone help please?

(Sorry for the long post)

I am afraid that is not exactly a Cloudflare related question and is better suited for StackExchange and alike.

Ok, thanks anyway.