Can'r run Cloudflared in Docker on Pi 4

Hi, new to Cloudflare, docker and Raspberry PI.
I’m attempting to run connector for a tunnel using Docker on Raspberry Pi 4. Pasted in the ‘docker run’ command from the Cloudflare website instructions but got this:

“latest: Pulling from cloudflare/cloudflared
docker: no matching manifest for linux/arm/v8 in the manifest list entries.
See ‘docker run --help’.”

Does that mean I can’t run it on my Pi with Docker and I have to do it another way, or can I change to command to make it download an appropriate version?

Are you using a 32bit OS on your rpi4?
What happens if you use this tag latest-arm64?

1 Like

Thanks. I was using 32 bit, after some thought switched to the 64bit Pi OS. I did get it to run but I suspect that its not running quite as it should. I run the docker command from a SSH, and it clearly is setting the tunnel up and the tunnel shows as ‘healthy’ and works fine - but the SSH prompt never returns - it just seems to hang. I fairly new to SSH too, but it does not look right. Then Tunnel remains healthy and working until i close the SSH session, when it dies.

So working, but not quite correctly.

This is due to you run in in the foreground, but you should run it in the background (detached).
To help you please provide us with your full command you run. (besides your tunnle_id!!!)

Please notice, that this is NOT a Cloudflare issue, but that is how processes in linux work. If the SSH session dies the process dies/gets killed.

Thanks. It’s this, plus the actual token:

docker run cloudflare/cloudflared:latest tunnel --no-autoupdate run --token

use the parameter --detached or -d. So you command should look like this:

docker run -d --name cloudflared cloudflare/cloudflared:latest tunnel --no-autoupdate run --token

This command:

  1. runs the command detached
  2. sets the name of the container to cloudflared (makes it easier to manage)

I generally recommend using a docker-compose.yml file. But if you are new to SSH you can start with docker run.

Have fun!

P.S.: for more info on docker run please read the docs: docker run | Docker Documentation

Thanks again - I’ll give this a go, and will get my docker skills up to scratch too.

Please report back, once you have done so - so we know if this solved the issue.

It worked, thanks for all your help. Tunnel healthy.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.