Cannot use custom domain in Worker quick edit when CF route is disabled

Hi, whenever I disable the CF generated worker route and just leave the custom domain route active it will not execute my worker within the quick edit. I noticed I need to enable the CF generated worker route in order to make it work. Whenever I put in the custom domain within quick edit and log the request.url, it always logs the CF generated worker route. It appears to be a bug ? Anyone experiencing this behavior as well ?

This is due to the new Quick Edit feature from this blog post:

They’re working on getting that custom domain routing working in the new Preview, but it’s going to be a tiny bit longer.

Thank you for clarifying!

1 Like

Yes, I also can’t run my worker in the preview box in the new editor, unless I turn on the domain. Which is risky since I’ve gotten DDOSed/massive credential stuffing on the domain version of my worker in prior months/years, since nobody can turn on the WAF on a domain. I never figured out how the secret URL (the worker is on a custom domain route, public facing) got leaked to the bots, but the domain wound up on some kind of “exploitable URL” block list passed around on the dark web and bots from VPNs started hammering it with login*.php GET requests on wrangler tail until I turned off the domain.

CF bring back the old editor until the new editor has feature parity.