Cannot start railgun

Hi,

I try to use the following command to start railgun:


service railgun start

But get the following errors:

Starting railgun:                                          [  OK  ]
Railgun successfully backgrounded, ensuring proper startup...
                                                           [FAILED]
Error starting Railgun as a daemon. Running in foreground...

Error starting: Error connecting to memcached server /tmp/memcached.sock: dial unix /tmp/memcached.sock: connect: no such file or directory
                                                           [FAILED]

I just follow the instructions in https://developers.cloudflare.com/railgun/user-guide/set-up/configuration-activation and use a socket file since railgun and memcached are in the same server, as below:

#memcached.servers = 127.0.0.1:11211
memcached.servers = /tmp/memcached.sock

Do I need to create an empty file memcached.sock manually under /temp?

Thanks

What told you use use a .sock file in /tmp? Clearly if that file isn’t there, memcached can’t connect. Memcached is supposed to create that file. Have you asked your host about this?

If you need further assistance with Memcached, I suggest you look around on serverfault.com

1 Like

Hi, @sdayman

Thank you for your reply. In the railgun document at https://developers.cloudflare.com/railgun/user-guide/set-up/configuration-activation, it said “It is also possible to specify the full path to a single socket file for memcached. Using a socket file is recommended for best performance if your memcached does not require network communication.”, that is the reason why I use a socket file instead of a host:port pair.

Actually I have search extensively on memcached help document https://memcached.org/ but cannot find info about socket file, so I ask here to see if I can get some helps. I will search on ServerFault to get more info.

I modify memcached configuration file as below:

OPTIONS="-s /tmp/memcached.sock -a 0766"

Then restart Memcached, and railgun and the issue is solved. Thank you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.