Cannot sign up in R2 beta

Stuck at step 2: complete purchase, click save payment information only results in a loading animation.
Tried both PayPal and card, did not work.

I got the same error :frowning:

Did you get it to work?

no :unamused::unamused::unamused:

Ahh yes, this happened to me too, at first I thought that my country or card was blocked by Cloudflare but I wasn’t getting any error or anything so I decided to f12 and inspect the network console and found out the page was getting a 404 when ever I clicked purchase.

This 404 error was not being caught and sent to the UI so it kept loading forever. The error said something like “Could not load user payment methods” so this is what I did to fix it.

I went to Home > Manage Account > Billing > Payment Info and created a payment plan there, retried to purchase R2 again and it worked. Hope this helps.

1 Like

in my case, the f12 did not show any web request. wired

Thank you… after a fustrating experience attempting to pay for R2, your advice worked.